AnsweredAssumed Answered

rx_path_rates settings for 1 MiS

Question asked by emi11 on Jun 17, 2016
Latest reply on Jun 20, 2016 by emi11

Environment: ZC702+ FMCOMMS3

OS:LINUX

 

Hi,

 

I need to set a sample rate to 2.048 MiS.

However bash returns with an error:

root@analog:/sys/bus/iio/devices/iio:device1# echo "2048000" > in_voltage_sampling_frequency

-bash: echo: write error: Invalid argument

The RX Path Settings are:

root@analog:/sys/bus/iio/devices/iio:device1# cat rx_path_rates

BBPLL:1048575999 ADC:32767999 R2:16383999 R1:8191999 RF:4095999 RXSAMP:4095999

the Strange thing is that in the DTB file these settings are different (verified in the DTB file)

/* BBPLL ADC R2CLK R1CLK CLKRF RSAMPL */

adi,rx-path-clock-frequencies = <983040000 245760000 122880000 61440000 30720000 30720000>;

 

There is no FIR filter defined:

root@analog:/sys/bus/iio/devices/iio:device1# cat filter_fir_config

FIR Rx: 0,0 Tx: 0,0

 

What do I need to change either in DTB or during run time to setup sample rate of 2048000 MiS

Thanks EMi

Outcomes