AnsweredAssumed Answered

ADV7604 produces Green/Black output on power up.

Question asked by JimC on Jun 13, 2016
Latest reply on Jul 21, 2016 by JimC

We have a system with multiple ADV7604 based input cards. On power-up the card connected to one particular source always produces a Green/Black output. This happens on multiple systems with different cards. Other inputs function normally and the cards in question function normally when connected to a different source. We know the following about this source:

1) The source does not supply +5V to our DVI interface.

2) The source does not read our EDID settings.

3) The source is outputting RGB video.

4) When we disconnect and reconnect the input, the video sometimes changes from green/black to full RGB with R and B swapped.

5) The source resolution is 800x480p60 with 840 total pixel per line and 1320 total total line per frame. That is assuming that the ADV7604 is detecting the video correctly. This resolution is fixed in the source and in our unit is configured to receive it.

6) We convert everyting coming into the ADV7604 to YCrCb 4:2:2 for processing. One theory is that the color space converter or the 4:4:4 to 4:2:2 converter is losing information. We don't know how to verify this.

 

Our system is installed at our customer's location in such a fashion that we cannot access the board itself to probe any signals.

We cannot get source to test with in our lab. It is custom hardware that is integrated into their system and there are no spare units available.

Outcomes