AnsweredAssumed Answered

FMC_HPC on ZC706

Question asked by keklaquoi on Jun 3, 2016
Latest reply on Jun 16, 2016 by keklaquoi

Hello !

 

I'm using a ZC706 board, and I had a FMCOMMS1 board plugged on the FMC_LPC port. Unfortunately, It seems that a pin is broken on this port, and I would like to try running my demo using the FMC_HPC port.

 

To do so, I changed my UCF file, and tried to set the FMC_HPC ont the software "XCOMM_DefaultInit defInit = {FMC_HPC". But it doesn't work.

 

I've read that on a post that putting "ps7Interface" variable to "1" in "XCOMM_InitI2C" function, would allow me to use the HPC port. But it doesn't work as well.

 

I tried also modifing the software code, but with no luck...

 

I've also read on another post (for the ML605 board), that the HPC port was a slave, and it needed a board plugged on the LPC port to work. Is it the same thing for the ZC706 ?

 

My initialization always fail at the "XCOMM_InitI2C" function call.

 

What modifications need to be done in the software to use two FMCOMMS1 cards on the FMC_HPC port of the ZC706 board?

 

Thank you in advance for your help,

 

Best regards,

 

Clément

 

Outcomes