AnsweredAssumed Answered

ADPD103

Question asked by Payal on May 31, 2016

Sir,

 

I am currently using the Eval board from Analog Devices - ADPD103. I am having some difficulties as the schematics of it are not provided!(Kindly post the needful)

 

1. I have issues when I am connecting any external photo diode(other than the one provided on the Eval board). The Photo Diode responds to the basic tests (coarse voltage variations when rapid movements of finger is done), but when I connect an LED it shows Zero Voltage.

 

2. I tested for a series of LED ranges .i.e. green/IR . It showed a comparable PPG graph for IR LED in conjunction with a respective the respective Photo diode when adjusted the no. of pulses/ LED current etc. But for green no adjustment seemingly worked. (I was suspecting some issue with the forward voltage drops as the IR LED has a lesser forward voltage than the red LED(which is the on board sample given for testing) and green needs a higher forward voltage). I guess a little insight on the driver circuit employed will be a lot useful. Any other advice on this aspect is welcome as well.

 

3. I wanted to run two or more Photo Diode channels at the same time.The Datasheet says to modify the register 0x14 from 0555(default value) to 0445 to activate PD5/6/7/8. But in all the cases I am able to get only channel one activated .i.e. PD1/PD5. Am I missing on something?(I have checked the register 0x3C , it is not on single channel mode)

 

 

Any help at the earliest would be really appreciated.

Outcomes