AnsweredAssumed Answered

ADIS16480 bring-up problems

Question asked by IslamAlaa on May 31, 2016
Latest reply on Jun 2, 2016 by IslamAlaa


Dear Guys,

 

I am working with an ADIS16480 unit and trying to interface it with an Arduino board (Arduino UNO board). and I am facing some problems doing that.

 

The test I am working on is the reading of the PROD_ID register (0x7E00) in a repetitive manner (which should results 16480 in decimal)

 

The problem is that, I see a very strange behaviour when trying to do so. When i write the address (0x7E00) on the SPI line, I get the same address value as the reply (0x7E00) instead of the product ID (16480)

 

This test caused some confusion to us when we first tried to bring it up, as the value sent as address was (16480) and resulted (16480) so, we thought that it worked well. but after debugging and trying to stream readings from the unit, we found out that behaviour.

 

Also, We monitored the current draw from the supply (supply is 3.3V using external supply unit), the current draw was very low (0.02 Amperes = 20 mA) Which is much lower that what is reported in the datasheet in the normal mode (254 mA in normal mode).

 

So, we made another test, where we just want to monitor the current and dis-attached all the lines except the 3 VDD lines (pins 10, 11, 12 in the breakout board) and the 3 GND lines (pins 7, 8, 9 in the breakout board).

 

So, appreciate your immediate help and support as usual.

 

Thanks

Outcomes