AnsweredAssumed Answered

BF70x ROM library compatibility

Question asked by JohnC-vid on May 13, 2016
Latest reply on Jul 25, 2016 by CommanderDave

I note that an application must be linked specifically to either the revision 0.0 or 1.0 ROM library.

Is it safe to assume that the entry points and signatures are now finalised at v1.0 and that future silicon revisions (which may well  have better implementations and additional functions in the ROM) will be fully back compatible.

 

I need to be confident that application firmware I generate now, linked to the v1.0 revision ROM library, will continue to work on production units well into the future with all subsequent processor revisions.

 

JohnC

Outcomes