AnsweredAssumed Answered

Automatic EQ Impulse window Not Initialized

Question asked by SteveGnome on Apr 24, 2016
Latest reply on May 26, 2016 by SteveGnome

I'm currently working on a project with an ADAU1701 board. I recently posted about a Comm Failure issue but using a different computer seems to have avoided that.

 

Now I'm trying to utilize the Automatic EQ system for my loudspeaker. I have made independent measurements in REW, then wrote a script to translate my frequency response into SigmaStudios _Very_ stringent requirements. I then went through the exercise of designing the filters and what not. Unfortunately It doesn't seem to work. In the process of narrowing it down, I constantly get an "not initialized to an object" crash. This is from the Impulse response hanning window. This is annoying because I'm not using the impulse response system for the Auto EQ. I'm using the Freq. Response.

 

I've selected the impulse response option to uncheck the "Apply Windowing" functionality, only to have it become re-checked as I use the system (opening, closing, saving ect. within Sigma).

 

I don't trust this Auto-EQ at all and I don't seem to be getting any sort of practical response out of my speakers.

 

I wonder if I was able to actually import an impulse response and use that data if this would go away. Unfortunatly I do not know what SigmaStudio's requirements are for an impulse response since no templates are provided in the sample measurements.

 

Anyone had any luck implementing Auto EQ?

Outcomes