AnsweredAssumed Answered

ADV7180 I2C problem

Question asked by andy.cruey on Apr 8, 2016
Latest reply on Apr 8, 2016 by andy.cruey

We’re trying to get the I2C communications working between the ADV7180 and an i.MX53 processor. I have a logic analyzer connected to the SDA, SCL, RST_n, and PWRDN_n pins on the ADV7180. What I see is the RST_n and PWRDN_n are high and a perfectly formed I2C slave address of 0x40 going out to the ADV7180, but it never ACKs the address. We even changed the address to 0x42 just to see if it was set to that address even though ALSB is pulled low. Still no ACK.

 

The only thing I can think of that might be the problem is that the Spartan 6 FPGA controlling the RST_n and PWRDN_n is set to have pull-ups on the I/O during config. That may be pulling the RST_n and PWRDN_n high too soon after power-up. Could that cause the I2C interface to be dead? I do see reasonable HS and VS coming out of the part, so that must not be dead.

 

I also tried pulling the RST_n low for ~200ms and tried to talk to it again, still nothing.

 

Oh, and I verified the oscillator is running at ~28.7MHz.

 

Any ideas from anybody?

 

Outcomes