AnsweredAssumed Answered

AD5292: Not responding to SPI

Question asked by a.c on Mar 24, 2016
Latest reply on Apr 7, 2016 by DRice

Greetings,

I am trying to control the AD5292 via SPI. However, it does not follow the commands I am sending (the wiper stays on mid-scale position). The SPI-message should be correct, I am attaching a few images from the oscilloscope. I am only transmitting two commands for now: 0x1802 for enabling writing, and 0x0700, which should set the wiper to about 75% of the maximum resistance. Both are sent multiple times, to be sure, but they still dont get recognized appropriately. I tried both with higher and lower SS/CLK delay. Frequency is set quite low, to ensure it wouldnt cause problems, I also tried using up to 100Khz. It should be noted that I was not able to catch rdy(on oscilloscope) being high, aswell that a few times the wiper was set appropriately, but that happened only thrice so far.

 

AD5292 is connected according to the datasheet:

- ~RESET to Vlogic (3.3V)

- Vss to 0V, Vdd to 15-25V; decoupled with 0.1µF and 10µF between them

- A to 13V, B to 0V (W is read as ~6.5V)

- EXT_CAP via 1µF to GNDlogic

- Vlogic to 3.3V from µC, GND to GND of µC; decoupled with 0.1µF and 10µF between them

- DIN to MOSI of µC

- SCLK to SPICLK of µC

- ~SYNC to SSL of µC

- SDO floating

- RDY either floating or read via oscilloscope

 

I am quite sure that the problem lies within the AD5292, as the SPI-package looks fine (16 CLK cycles, Bits are correct, MSB read first). I also tried using two different AD5292, but the result was the same.

 

Thank you in advance.

Outcomes