AnsweredAssumed Answered

No data from AD9625

Question asked by rogro on Mar 18, 2016
Latest reply on Mar 21, 2016 by rogro

Hi,

 

I am using an AD9625-fmcadc2 board mounted on a ZC706. I am running petalinux on which I have updated the kernel to the xcomm_zynq_4_0 branch from ADI and cross-compiled libiio and IIOD. I am currently just trying to get a few blocks of data out to test my data flow and am unable to do this. I have tried using IIO Oscilliocope and I can read the operating parameters and have set the test mode but I don't get any data displayed on the plot. To make sure the HW is OK I have booted the board with the ADI Linux image. I was able to setup the ADC and get data out and displayed on the IIO Oscilloscope plot.

There are no errors in the boot sequence. From dmesg:

...

cf_axi_jesd204b_v51 44a91000.jesd204: AXI-JESD204B 6.1 Rev 2, at 0x44A91000 mapped to 0x8098a000,

...

ad9467 spi32766.0: AD9625 PLL LOCKED

...

cf_axi_adc 44a10000.axi_ad9625: ADI AIM (9.00.b) at 0x44A10000 mapped to 0x80a00000, probed ADC AD9625 as MASTER

 

I used zynq-zc706-adv7511-ad9625-fmcadc2.dts (from the ADI kernel) as an example of how to setup the device tree. I have attached my system-top.dts file. I also followed the example code in ad9361-iiostream.c to setup and start an IIO data stream, but still no luck.

 

Am I missing something obvious here?

Is there anything else I can do to debug this?

 

thanks,

Ron

Attachments

Outcomes