AnsweredAssumed Answered

ADV7619 HDCP Failure with Apple TV

Question asked by rpmarchand Employee on Mar 11, 2016
Latest reply on Jun 9, 2016 by JeyasudhaMuthuPerumal

Hello,


I'm having an issue with HDCP with Apple TV (gen 3, A1469).  If the Apple TV is connected before the ADV7619 is initialized it will report an HDCP authentication failure and it seems unrecoverable. 

 

Here is what I tried.

  1. Write 0x80 to HDMI register 0xFF to reset the chip
  2. Connect Apple TV
  3. Run the initialization scripts for the ADV7619 eval board.

 

Few registers that show the states:

HDMI register 0x5 returns 0xB0. Indicating the input stream which is processed by the HDMI core is not HDCP encrypted. This status won’t change no matter what the source is.

IO register 0x6F returns 0x01. Indicating that Current Frame in Port A is encrypted.

HDMI Register 0x4 returns 0x23. Indicating that HDCP Key is read, no error in reading, and RI is not expired.

All other HDCP related interrupt status bit are all cleared.


What’s worst, I can not recover the HDCP status by changing different source.  For example i tried to connect another source (keeping the ADV7619 powered and initialized) and it caused that source to stop outputting anything due to failed HDCP authentication.  The only way to recover it would be remove source (Apple TV) and reset the ADV7619 and rerun the initialization scripts.

 

This same issue has been observed on a several products that use the ADV7619.  I have not tried this yet on an evaluation board but plan to. 


Please let me know what i might be doing wrong!

Outcomes