AnsweredAssumed Answered

Pybomb Errors During gr-iio Install

Question asked by JFL_AD on Feb 4, 2016
Latest reply on Apr 28, 2017 by pcercuei

I am presently running UBUNTU 14.04 with GNU Radio installed in a directory named "/home/lab2/GnuRadioTop." When attempting to add gr-iio using pybombs, I get the following errors:

 

lab2@lab2-Latitude-E6420:~/GnuRadioTop$ sudo pybombs -p /home/lab2/GnuRadioTop  install gr-iio

 

|

 

\- gr-iio

 

  1. PyBombs.install - INFO - Installing package: gr-iio
  2. PyBombs.Packager.source - WARNING - Build dir already exists: /home/lab2/GnuRadioTop/src/gr-iio/build

   

Building: (100%) [============================================================================================================]

 

5%] Building CXX object lib/CMakeFiles/gnuradio-iio.dir/device_source_impl.cc.o

 

/home/lab2/GnuRadioTop/src/gr-iio/lib/device_source_impl.cc: In static member function ‘static iio_context* gr::iio::device_source_impl::get_context(const string&)’:

 

/home/lab2/GnuRadioTop/src/gr-iio/lib/device_source_impl.cc:119:44: error: ‘iio_create_usb_context’ was not declared in this scope

 

       ctx = iio_create_usb_context(vid, pid);

 

                                            ^

 

make[2]: *** [lib/CMakeFiles/gnuradio-iio.dir/device_source_impl.cc.o] Error 1

 

make[1]: *** [lib/CMakeFiles/gnuradio-iio.dir/all] Error 2

 

make: *** [all] Error 2

 

  1. PyBombs.Packager.source - ERROR - Build failed. See output above for error messages.
  2. PyBombs.Packager.source - ERROR - Problem occured while building package gr-iio:

   

Build failed.

 

  1. PyBombs.install - ERROR - Error installing package gr-iio. Aborting.

 

lab2@lab2-Latitude-E6420:~/GnuRadioTop$ 

 

Any help would be greatly appreciated.

 

Outcomes