AnsweredAssumed Answered

Problem running GRC IIO examples on a host computer with Ubuntu

Question asked by King on Dec 23, 2015
Latest reply on Feb 23, 2016 by pcercuei

Hi,

   I was able to run iio examples, cycric-sine.grc,  on ZC706 successfully. However, when I tried to run the same examples on a host computer, WX GUI Scope Sink doesn't pop up a GUI window and it would stop after a few seconds.

 

Here are the messages displayed:

Executing: "/home/kc/test/iio-examples/cyclic_sine.py"

 

Using Volk machine: avx_64_mmx

 

>>> Done

 

I changed WX GUI Scope Sink to a QT GUI Frequency Sink, but it has the same result.

I did change the hostname on the FMComms5 Source and Sink to the ZC706 IP address. The host computer is connected to ZC706 via an Ethernet switch and I can confirm TX port is outputting the correct signal.

ADI IIO Oscilloscope works fine on the host computer.

Host PC: Ubuntu 14.04.3 LTS with GNU Radio: 3.7.8.1

Hardware: FMComms5 & ZC706 (with image 2015_R1-2015_11_17)

 

Any idea? I'd appreciate your help. Thanks.

KC

Outcomes