AnsweredAssumed Answered

iio scope start error using gtk+ 2.x and gtk3 in the same process

Question asked by bhatnagar.vaibhav81 on Nov 18, 2015
Latest reply on Nov 25, 2015 by bhatnagar.vaibhav81

Hello,

 

I am using ZC706 with EVB-AD6676. I am running it with the prebuild image from SDCARD.

When I connect a display I can successfully run the iio scope as expected.

Now I am trying to get the iio scope under ubuntu. I followed given steps at https://wiki.analog.com/resources/tools-software/linux-software/iio_oscilloscope

I installed all the dependencies but at last I have this error :

GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported. However I completely remove gtk3 and also gedit (that uses gtk3), but it is still there and I am unable to run ./osc.

 

I tried to use only gtk3 by chaing the depencies in Make file but libgtkdatabox-0.9.2-0 uses it so it appears again.

Please let me know if there is any solution?

 

BR./

 

Vaibhav

Outcomes