AnsweredAssumed Answered

ADuC7020 serial download using a virtual serial port

Question asked by Tangle on May 9, 2011
Latest reply on May 17, 2011 by Tangle

G'day,

 

This has been killing me for weeks, but I can't get my EVAL-ADuC7020MKZ board to take a program using the serial downloader.  I'm using the cable provided in the box via a USB-serial converter and powering the board externally from 9V.

 

I've tried the ARMWSD software.  It does not reset the board as it says in the instruction but tells me to reset the board manually.  Either way if I use the method in the ADuC documentation, or the implied ARMWSD method the board does not respond.  The board seems to enter the serial download mode ok because the program (?) that is on there stops running (the LED goes off) when I reset it holding the 'SER DLOAD' button.  I have tried two different USB-serial converters, one is a PL2303, the other is a FT232RL.

 

I have even tried sending the backspace character down the serial line manually while the board is in serial download mode and there is no response.

 

Has anyone else had this/a similar problem?  Is there something fundamental that I am missing?  Any ideas?

 

Thanks

Lee.

Outcomes