AnsweredAssumed Answered

Problem with GPIO_ADAU1701

Question asked by Suzanne.li on Apr 28, 2011
Latest reply on Jan 26, 2015 by CraigD

  Recently, we are using the GPIO function of ADAU1701, We want to increase and decrease the volume using PUSH-BOTTON VOLUME CONTROL, but we had a problem.

 

  We found that it worked well while connected to the computer, but it didn't work in self-boot mode. And if we wrote asending values in the table of  PUSH-BOTTON VOLUME CONTROL (eg: 0~1), in self-boot mode it always worked in the minimum volume(0), the bottons didn't work; if we wrote desending values (eg: 1~0), the volume could only be maximum and minimum as we pushed the buttons, no matter how many values we put in the table.

 

  Then we found an example project in Version 3.2, it works very well, either in self-boot mode or connected to the computer. We noted that in the example project there was a switch for comparing the PUSH-BOTTON VOLUME CONTROL and bypass, and if we deleted that switch, the same problem appeared...

 

  After that we did a lot of tests, it appeared that if we use PUSH-BOTTON VOLUME CONTROL, there must be a switch to ensure that ADAU1701 works well in self-boot mode.

 

  Does this switch mean something? Or is it a bug? Or it's just that we didin't set the project properly?

 

  The two attaches are the example project and the project without switch.

 

  Looking forward to the resolutions! Thanks very much!

Outcomes