AnsweredAssumed Answered

FMCOMMS2 + ZedBoard HDL 2015_r1 fails timing

Question asked by seaskifool on Sep 15, 2015
Latest reply on Sep 21, 2015 by larsc

There have been a few postings on this topic, but I have not really seen any answer that fits.

 

Using Vivado 2014.4.1, running on an updated Windows 7 Pro machine, I do the following to try and build:

 

1. issue the make command (using Cygwin) in the library directory - all is well - no errors

2. When I do the same in projects/fmcomms2/zed, the build fails timing.

 

I tried to go back to 2014_r2, but it has no makefiles (tried using the 2015_r1s, but not surprisingly they are not directly compatible).

 

I am just trying to make a small change by connecting a few of the Zynq PS peripherals (e.g. SPI, UART) to extarnal pins via MIO, but that does not work (started with this, then backtracked to as downloaded build). Plan to edit system in Vivado, as not quite sure how to add it to the build script.

 

Assistance needed on two matters:

1. How to make as downloaded 2015_r1 build and meet timing

2. How to add a few MIO peripherals to reference build and not break things (there is a post suggesting that one has to edit scripts to make it work which I find strange).

 

Cheers!

Outcomes