AnsweredAssumed Answered

Compile the IIO blocks error

Question asked by helloAnalog on Sep 9, 2015
Latest reply on Sep 11, 2015 by pcercuei

hi,I have already installed gnuradio (3.7.5). I refer to the tutorial on ADI Wiki (GNU Radio [Analog Devices Wiki])。I'm with a compiler error. The error like this:

-- The CXX compiler identification is GNU 4.9.2

-- The C compiler identification is GNU 4.9.2

-- Check for working CXX compiler: /usr/bin/c++

-- Check for working CXX compiler: /usr/bin/c++ -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- Check for working C compiler: /usr/bin/cc

-- Check for working C compiler: /usr/bin/cc -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Boost version: 1.55.0

-- Found the following Boost libraries:

--   filesystem

--   system

-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28")

-- checking for module 'cppunit'

--   found cppunit, version 1.13.2

-- Found CPPUNIT: /usr/lib/x86_64-linux-gnu/libcppunit.so;dl 

-- Found Doxygen: /usr/bin/doxygen (found version "1.8.9.1")

CMake Error at CMakeLists.txt:99 (find_package):

  By not providing "FindGnuradio.cmake" in CMAKE_MODULE_PATH this project has

  asked CMake to find a package configuration file provided by "Gnuradio",

  but CMake did not find one.

 

  Could not find a package configuration file provided by "Gnuradio"

  (requested version 3.7.2) with any of the following names:

 

    GnuradioConfig.cmake

    gnuradio-config.cmake

 

  Add the installation prefix of "Gnuradio" to CMAKE_PREFIX_PATH or set

  "Gnuradio_DIR" to a directory containing one of the above files.  If

  "Gnuradio" provides a separate development package or SDK, be sure it has

  been installed.

 

Has anyone ever had such a problem?Please help me。thinks

Outcomes