AnsweredAssumed Answered

IMASK not written through debugfs.

Question asked by kv193 on Aug 20, 2015
Latest reply on Aug 27, 2015 by kv193

For debug purposes I want disable all IRQs (may be except own). I try:

=====================================================

root:/sys/kernel/debug/blackfin/cec> ls                                        

EVT0          EVT12         EVT2          EVT6          EVT_OVERRIDE  IPRIO    

EVT1          EVT13         EVT3          EVT7          ILAT                   

EVT10         EVT14         EVT4          EVT8          IMASK                  

EVT11         EVT15         EVT5          EVT9          IPEND                  

root:/sys/kernel/debug/blackfin/cec> ls -l IMASK                               

-rw-------    1 root     root             0 Jan  1 00:21 IMASK       

root:/sys/kernel/debug/blackfin/cec> cat IMASK                                 

0x0000ffff                                                                     

root:/sys/kernel/debug/blackfin/cec> echo 0x0 > IMASK                         

root:/sys/kernel/debug/blackfin/cec> cat IMASK                                 

0x0000ffff                                                                     

root:/sys/kernel/debug/blackfin/cec>

=====================================================

Why IMASK is not writable?

Of course, I successfully disable obstructive timer irq by write:

=============================================

root:/sys/kernel/debug/blackfin/ctimer> cat TCNTL                              

0x00000003                                                                     

root:/sys/kernel/debug/blackfin/ctimer> echo 0x0 > TCNTL

=============================================

But why I can not write to IMASK directly?

Outcomes