AnsweredAssumed Answered

EVAL-ADuCM320EBZ not detected with J-link

Question asked by sookah on Aug 12, 2015
Latest reply on Aug 14, 2015 by sookah

Hi,

 

To evaluate some high speed analog signals I have purchased the EVAL-ADuCM320EBZ board. I followed the ADuCM320 starting guide closely to set everything up (http://www.analog.com/media/en/technical-documentation/user-guides/ADuCM320_Getting_Started_Guide_UG-692.pdf). I have used the DIO project in keil, the project compiles fine, however when trying to flash the compiled file, the j-link does not find the device on the SW interface (error "No Cortex-M SW Device Found").

 

In kiel I have tried "configure flash tools > utilties > j-link .. settings" and the "debug" tab; as can be seen on the picture below the "SW device" panel does not show any hardware. I tried changing max clock and Reset options but none helped.

Capture.JPG

Below is the image of how i am connecting the hardware for SW mode. Jumpers LK1, LK2, LK4 and LK6 have been used.

photo.JPG

Following is the screen cap of my device driver

Capture2.JPG

 

The problem:

I guess the fundamental problem here is why is my hardware not being detected? Is it the way I placed the jumpers for the SW mode or software in the IDE. Also (as an option) can I program my eval module via ftdi pinouts to put my binary executable files? I also read that maybe my eval board has no firmware, if so how do i check ? and how can I update firmware (for both j-link or eval module)?

 

This is my first post on a forum..ever.. so if I miss something please let me know, I highly appreciate the efforts and thank you for your time.

Outcomes