AnsweredAssumed Answered

Bug (undocumented feature) in ADIS Eval Software

Question asked by BrandonjNapier on Aug 3, 2015
Latest reply on Aug 17, 2015 by NevadaMark
Branched to a new discussion

I noticed something unusual while running tests with the ADIS Evaluation software that might cause some problems for people. 

 

Test Setup

IMU: ADIS16448

Eval Software Version: 1.14.0

External power supply powering IMU

External clock signal sent to IMU

 

 

Using the Registry Access page, I changed SMPL_PRD to 100 to configure the IMU to use the external clock signal to sample the IMU data at 1kHz.  On the "main" page (the one with the strip charts), I can verify that the IMU is configured to use the external clock because when I turn the clock signal on/off the data will reflect this by either outputting data or flat-lining.  I go to the Data Capture page, making the appropriate changes to Advanced Options, and collect my data.  So long as I stay at the Data Capture page, everything works fine and I can collect several different data files with no problem. 

 

The problem arises when I close the data capture page.  The SMPL_PRD value changes to 101, which configures the IMU to use the internal clock.  I verified that the IMU is really using the internal clock, the same way I verified it was using the external clock before.  I tried this whole process with and without saving my changes to flash memory, and I get the same result both ways.

 

This is not a huge problem for me, I just have to remember to change the setting again before collecting more data.  Not sure if you would consider this a Bug, or just an Undocumented Feature, but I though I should mention it. 

Outcomes