AnsweredAssumed Answered

AD5933 I2C troubleshooting

Question asked by rosedp on Jul 22, 2015
Latest reply on Jul 30, 2015 by rosedp

I am hoping this is a simple problem with a simple answer and I just haven't been able to see it yet. I'm using the AD5933 and have laid out my circuit in a very similar manner to the example shown in CN217. For the time being I'm using an FTDI FT232H USB-to-I2C adapter to interface the AD5933 to my PC and using Python to issue the I2C commands as described in the datasheet of the AD5933. Generally speaking, my Python code works and I can make measurements and run sweeps on the AD5933... at first. However, after a while it appears that the AD5933 locks up and holds the SDA/SCL lines low indefinitely. I've tried my adapter with other I2C devices and don't have any problems. I've switched out AD5933 chips with the same result, works at first, then locks up. I've even verified that it is the AD5933 that is pulling the bus lines low. What I don't understand is why, and how do I fix it? I've locked up 3 chips and at $33 each I'm hesitant to continue. Can anyone provide any insight on this?

Outcomes