AnsweredAssumed Answered

Blimp error message while setting ExternalOSD resolution

Question asked by ChrisInSeoul on Jul 1, 2015
Latest reply on Jul 7, 2015 by ChrisInSeoul

I'm trying to change the size of the external OSD video (PIP) to be full screen.

But using Blimp on the eval board sample OSD project, I can't change the resolution at all.

When I open the project, navigate to the ExternalOSD element, and select it, I get these two errors:

Error 0:

Description:     The type or namespace name 'UCHAR' could not be found

                       (are you missing a using directive or an assembly reference?)

File:      ExternalApi.cs

Line:     534

Col:      42

Error 1 (same description and file, just different line/col):

Line:     572

Col:      41

 

Ignoring this error, I tried to change the resolution, default value was 480p.

No matter what value I put in this field, it doesn't "take".  I tried 720p, which was an option,

and also various custom values, both larger and smaller than 480p.  Nothing would be accepted except 480p.

 

Q: How can I change the resolution of the ExternalOSD element?

 

Details:

Eval Board:          ADV8005

Blimp release:     3.8

Sample Project:     /SampleProject/ADV800x/AVR_OSD_DEMO/ProjectFiles/

Filename:               flowOSD_rev3.osl

 

As a quick test, I made a blank project, accepted the default startup blank page, which I then set to be 1280 by 720.

Then, I was able to add an ExternalOSD element.  It came into being with a default value of 480p, which I changed it to 720p with no problem.  Interestingly, just to check what the error would be if I forced the ExternalOSD to be larger than the main page, I tried a custom resolution of 1281 by 721.  It accepted this with no error message.

 

If I have to, I will run with my simple Blimp project of only one element, the External OSD. But in the interest of time, I was hoping to just tweak the sample project to minimize the learning curve during what is still an evaluation effort.

 

-Chris

Outcomes