AnsweredAssumed Answered

Failure Performing Scan Test (SADA + EZ-BRD)

Question asked by scottw on Jun 28, 2015
Latest reply on Jun 28, 2015 by scottw

Before I plop down for a new SADA board, I want to make sure I haven't missed anything simple...

 

My setup is a SADA V1 (BOM Rev 2), 21489 EZ-BRD, Windows XP SP3, Visual DSP 5.1.2

 

I am running inside a VM on OS X, but since the USB devices are properly installed in Windows, and the error does not occur until later in the process, I will assume for the time being that the issue is not related to the virtual machine.

 

In VisualDSP++, when connecting to the target board, I'm getting an error 0x8004804b as in the attached screenshot.

 

Screen Shot 2015-06-28 at 2.10.59 PM.png

 

Testing in ICE Test, I get a failure "Performing scan test" as shown here. "Incorrect byte found at position 0"


Screen Shot 2015-06-28 at 1.26.17 PM.png


This would seem consistent with the failed loopback test. Note that the incorrect values I get back on subsequent tests seem random.

 

I've attached the SADA to a 21469 as well with the same result - which (hopefully) means it's an issue with the SADA and not the eval boards.

 

Going through the troubleshooting guide (EE175), here are the things that I've done...

 

Some evaluation board problems can be caused by incorrect switch or jumper settings. Each board setup is different and switches/jumpers may be changed depending on user requirements. If you are having difficulties operating or connecting to the board, you may find the functionality of the board has changed because switch or jumper settings have been changed. Analog Devices recommends that you set your board back to the factory default settings.

 

Confirmed that the switch settings on the eval board are all correct.

 

If you encounter problems connecting to your evaluation board after programming the flash, try changing the boot mode select switch or jumper.

 

Tried with boot mode 0, 1, 2 Just in case there was some ugly code in 1 or 2.

 

Additionally, the LEDs are as follows prior to the test:

 

IMG_0330.JPG

 

But as soon as the loopback fails, the MONITOR led turns off. I'll have to dig to find a windows machine that I can test with to make sure it's not a virtual machine issue... Starting there now...

 

Thanks for any insight you might be able to provide.

 

Scott

Outcomes