AnsweredAssumed Answered

AD9361, GNURadio and IIO-Oscillocope sampling rate

Question asked by SMiles on Jun 22, 2015
Latest reply on Jun 30, 2015 by pcercuei

I am working with a 2x fmcomms5 & Zync702 setup, and have been having some strange issues. Both systems are set up with IIO-Oscilloscope and GRC built and installed according to your wiki, and I am controlling them via direct ethernet remote context on two laptops running Ubuntu, also with IIO-Oscilloscope and GRC on them. I changed the device name in the fmcomms2_source_impl.cc file to cf-ad9361-A so that the GRC source block would work for my fmcomms5, and it seems to work. I can transmit and receive through IIO scope with no problems, but I've been having trouble trying to transmit through GRC.

 

Many times when I run a flowgraph with an Fmcomms2 Sink block, I'll see high power artifacts of my transmitter sample rate in the receiver alongside the signal I am looking for (typically I'll see +/- 0.25 and +/-0.5 times my Tx sampling frequency). This tends to happen  more often/severely with higher sample rates and more complicated flowgraphs. Sometimes, these artifacts will persist even after I kill the flowgraph, and the only way to get rid of them is to reset the Zync board, or to go into IIO scope and enable then disable a DDS tone.

 

I think it's related to the device buffer, since increasing the buffer size in GRC seems to cause the problem to happen less frequently (I usually have it set to 512k or 1M). Additionally, I noticed that one of the first things enabling a DDS tone in IIO Scope does is to destroy the existing device buffer.

 

I can get limited success broadcasting a singe unmodulated tone without these artifacts showing up, but if I increase the sample rate past ~12MSps I'll start to see them. I also have a GMSK encoder built into a different flowgraph, and in that one I can only go up to 5MSps without seeing them consistently. If anyone might have an idea about what this issue could be, or what I can do to get around it, that would be wonderful. Thanks!

Outcomes