AnsweredAssumed Answered

AD7147 SPI Communication problem

Question asked by SKKU_KIM on Jun 12, 2015
Latest reply on Jul 6, 2015 by DarraghCorrigan

Hi. I'm having some issues with AD7147 SPI communication.

 

I tried reading a register from it but it returns 0. I configured the AD7147 registers as it says in the Power-Up sequence of the datasheet.

 

As it says, I wrote th Bank2 registers at Address(0x080), data, Bank1 registers(0x000), data and write Bank1 register(0x01), data.

 

     * To send those registers in SPI, I used (0xE080), (0xE000), (0xE001),

 

and I tried to read CDC 16-bit conversion data which is Bank1 register at Address(0x00B).

 

    * I used (0xE40B)

 

I'm using a STM32F103 microcontroller, I use its 3.3V supply for the AD7147, I connect it both to the V-Drive and the Vcc pin.

 

I connect  microcontroller's NSS pin to CS pin in AD7147(pin 16), SCLK pin to SCLK pin (pin 15), MOSI pin to SDI pin(pin 14), MISO pin

 

to SDO pin (pin 13). And I also connected GND pin.

 

    *BIAS, INT, AC sheld is not connected ( I owned I2C version AD7147-1, but it perfectly work without those pins)

 

I tried to read the data from AD7147 with other microcontroller like Arduino uno, but it still doesn't work.

 

It returns 0 and when i touch the SDO connection it returns 0xFF and 0x00 repeatedly.

 

So, I want to say is there any connection mistake or sending register problems in my process.

 

I attach schematic of my circuit.

 

Thank you very much.

Attachments

Outcomes