AnsweredAssumed Answered

adf4351-udc-rx-pmod devices in ad9361?

Question asked by HStoner on Jun 4, 2015
Latest reply on Nov 20, 2015 by charlyelkhoury

My apologies if this shows up as duplicate... I tried sending this question to some discussion group yesterday, but now can't find any reference to that, and I'm not sure where I sent it... so I'll ask it here.

 

We have a couple of different software revisions we've been running under linux on the ZedBoard / FMCOMMS3  evaluation boards.  In one of those versions, the device tree source file zynq-zed-adv7511-ad9361-fmcomms2-3.dts includes a file 'adi-fmcomms3-up-down-converter.dtsi', which adds two devices... adf4351-udc-tx-pmod and adf4351-udc-rx-pmod.   When the system comes up, there are 7 iio device folders created under /sys/bus/iio/devices/, including iio:device3 and iio:device4, which are for the two adf4351 devices.

 

In the other software version, the source file zynq-zed-adv7511-ad9361-fmcomms2-3.dts does not exist, and the closest file is simply zynq-zed-adv7511-ad9361.dts.   In this device tree, there is no inclusion of the adf4351... devices.  When this system boots up, there are only 5 iio device folders created under /sys/bus/iio/devices/.

 

I can see that there used to be adf4351 synthesizers on the FMCOMMS1 boards.   But I am not sure whether those adf4351 device files are even needed for the ad9361 device?  If so, what are they used for?

 

I have tried removing the inclusion of the file adi-fmcomms3-up-down-converter.dtsi from the system that includes them.   When I do, I get only 5 iio devices... there are no adf4351 devices registered.   But everything in iio-oscilloscope and ad9361-iiostream appears to run correctly in both cases.

So are these adf4351 devices used for anything?   Is their initialization just ignored when the adf4350 driver is initialized?

 

Thank you,

-Howard

Outcomes