AnsweredAssumed Answered

ADV7283 output video gap

Question asked by JerryS on May 26, 2015
Latest reply on Jul 23, 2015 by JerryS

Hello, Sir

 

I used ADV7283 in my design.

During test ADV7283 video board with ADI initial EVB settings, I found some problem as below.

Test condition: camera module output (CVBS/S-Video) --> ADV7283 --> Freescale i.MX6 --> Panel

a. CVBS input AIN4 from camera module in, it seems to there are 5 pixel gap between top of panel and active video.

    after setup ADV7283 register 0x04[7]=1 for BT.656-4 compatible, this video gap become to 1 pixel as below picture.

b. S-Video input Ain 5/6 from DVD load, it seems to there are 6 pixels gap between top of panel and active video.

    after setup ADV7283 register 0x04[7]=1 for BT.656-4 compatible, this video gap become to 2 pixel as below picture.


Action test:

a. test ADV7283 internal color bar in video board, it seems to ok without any pixel gap.

b. same camera module input to ADV7283 EVB(ADV7283+ADV7391) and video output to any panel, it seems to ok without any pixel gap.

c. I tried to enable reg 0x31, NEWAVMODE= high and adjust the VSBHO, VSBHE, VSEHO, VSEHE..etc, but it is not work active.

    is it any step my missing? or ADV7283 doesn't support this adjustment because there are no Hsync and Vsync pins.


Would you please kindly give me some suggestions?


1. CVBS input without BT-656-4 enable.

CVBS input without BT-656-4 enable.jpg

2. CVBS input BT-656-4 enable.

CVBS input_BT-656-4 enable.jpg

3. S-Video input without BT-656-4 enable.

S-Video input without BT.656-4 enable.jpg

 

 

4. S-Video input BT-656-4 enable.

S-Video input_BT.656-4 enable.jpg

5. In my video board, ADV7283 internal test pattern color bar.

Color bar test.png


Outcomes