AnsweredAssumed Answered

Zynq USB mouse/keyboard broken in the 3.19 ADI kernel

Question asked by henry10210 on May 25, 2015
Latest reply on Jun 24, 2015 by zynq-pats

Hello, I am trying to get Michal Simek or Lars Clausen to clarify the Zynq USB problem I just noticed today.  I have been using ADI Zynq kernel (https://github.com/analogdevicesinc/linux.git, xcomm_zynq branch) that supports the Zedboard USB.  Last year, I figured out how USB worked on Zedboard using the ADI 3.15 kernel and documented it in my blog (http://henryomd.blogspot.com/2014/11/understanding-linux-serial-device.html).  I vaguely recall that the USB mouse worked even up to 3.18.  Since now I just pick up the latest ADI kernel update, I picked up 3.19 recently without realizing it, and USB mouse/keyboard is not working any more.  I diffed the my 3.15 and 3.19 kernel and realized that the USB related files documented in Xilinx driver page USB section (http://www.wiki.xilinx.com/Linux+Drivers) are MISSING in the 3.19 kernel--except the mainlined files.  These missing files are what enables USB on Zedboard, the last time I looked into it in my blog.

 

I am not sure whether the xcomm_zynq is still the correct branch to use to pick up zynq specific files that are NOT yet mainlined, or whether there is something missing in the DTS file (like the "dr_mode").  I want to stick with the recommended method, whether it is just to stay in the zynq specific repository, or pick up the proper fix in the mainline kernel.  Can someone (Lars or Michal) from ADI/Xilinx please comment?

Outcomes