AnsweredAssumed Answered

USB problem with ADV7511 reference design on zedboard

Question asked by siliconfrog on May 13, 2015
Latest reply on May 14, 2015 by siliconfrog

Hello,

 

I've got a problem with USB connection when I tried do the reference design of ADV7511 on zedboard.

 

I exactly followed the steps instructed in http://wiki.analog.com/resources/tools-software/linux-drivers/platforms/zynq

I implemented this design in Vivado 2014.2 on Linux-64.

 

The project and library files are updated to branch 'master', and kernel source files are updated to branch 'xcomm_zynq'.

 

I've checked hardware in Vivado, tried to modify the device-tree, and tried different settings of jumper JP2 and JP3.

 

However, is seems there is some problem in vbus power supply.

 

Here is the log.

 

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

zynq-uboot> run sdboot

Copying Linux from SD to RAM...

Device: SDHCI

Manufacturer ID: 27

OEM: 5048

Name: SD04G

Tran Speed: 50000000

Rd Block Len: 512

SD version 2.0

High Capacity: Yes

Capacity: 3.7 GiB

Bus Width: 4-bit

reading uImage

 

3267648 bytes read

reading devicetree.dtb

 

10565 bytes read

## Booting kernel from Legacy Image at 03000000 ...

   Image Name:   Linux-3.19.0-g5b0956e

   Image Type:   ARM Linux Kernel Image (uncompressed)

   Data Size:    3267584 Bytes = 3.1 MiB

   Load Address: 00008000

   Entry Point:  00008000

   Verifying Checksum ... OK

## Flattened Device Tree blob at 02a00000

   Booting using the fdt blob at 0x02a00000

   Loading Kernel Image ... OK

OK

   Loading Device Tree to 1fb4f000, end 1fb54944 ... OK

 

Starting kernel ...

 

Uncompressing Linux... done, booting the kernel.

Booting Linux on physical CPU 0x0

Linux version 3.19.0-g5b0956e (siliconfrog@siliconfrog-OptiPlex-990) (gcc version 4.8.3 20140320 (prerelease) (Sourcery CodeBench Lite 2014.05-23) ) #11 SMP PREEMPT Tue May 12 20:55:42 HKT 2015

CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d

CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache

Machine model: Xilinx Zynq ZED

bootconsole [earlycon0] enabled

cma: Reserved 128 MiB at 0x17800000

Memory policy: Data cache writealloc

PERCPU: Embedded 9 pages/cpu @dfb9a000 s7552 r8192 d21120 u36864

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 130048

Kernel command line: console=ttyPS0,115200 root=/dev/mmcblk0p2 rw earlyprintk rootfstype=ext4 rootwait

PID hash table entries: 2048 (order: 1, 8192 bytes)

Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)

Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)

Memory: 381624K/524288K available (4345K kernel code, 264K rwdata, 1692K rodata, 208K init, 132K bss, 11592K reserved, 131072K cma-reserved, 0K highmem)

Virtual kernel memory layout:

    vector  : 0xffff0000 - 0xffff1000   (   4 kB)

    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)

    vmalloc : 0xe0800000 - 0xff000000   ( 488 MB)

    lowmem  : 0xc0000000 - 0xe0000000   ( 512 MB)

    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)

    modules : 0xbf000000 - 0xbfe00000   (  14 MB)

      .text : 0xc0008000 - 0xc05ed8c8   (6039 kB)

      .init : 0xc05ee000 - 0xc0622000   ( 208 kB)

      .data : 0xc0622000 - 0xc0664240   ( 265 kB)

       .bss : 0xc0664240 - 0xc06852ec   ( 133 kB)

Preemptible hierarchical RCU implementation.

        RCU restricting CPUs from NR_CPUS=4 to nr_cpu_ids=2.

RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=2

NR_IRQS:16 nr_irqs:16 16

L2C-310 erratum 769419 enabled

L2C-310 enabling early BRESP for Cortex-A9

L2C-310 full line of zeros enabled for Cortex-A9

L2C-310 ID prefetch enabled, offset 1 lines

L2C-310 dynamic clock gating enabled, standby mode enabled

L2C-310 cache controller enabled, 8 ways, 512 kB

L2C-310: CACHE_ID 0x410000c8, AUX_CTRL 0x76360001

slcr mapped to e0804000

zynq_clock_init: clkc starts at e0804100

Zynq clock init

sched_clock: 16 bits at 54kHz, resolution 18432ns, wraps every 1207951633ns

timer #0 at e0806000, irq=16

Console: colour dummy device 80x30

Calibrating delay loop... 1332.01 BogoMIPS (lpj=6660096)

pid_max: default: 32768 minimum: 301

Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)

Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)

CPU: Testing write buffer coherency: ok

CPU0: thread -1, cpu 0, socket 0, mpidr 80000000

Setting up static identity map for 0x41bff8 - 0x41c050

CPU1: thread -1, cpu 1, socket 0, mpidr 80000001

Brought up 2 CPUs

SMP: Total of 2 processors activated (2664.03 BogoMIPS).

CPU: All CPU(s) started in SVC mode.

devtmpfs: initialized

VFP support v0.3: implementor 41 architecture 3 part 30 variant 9 rev 4

NET: Registered protocol family 16

DMA: preallocated 256 KiB pool for atomic coherent allocations

cpuidle: using governor ladder

cpuidle: using governor menu

hw-breakpoint: found 5 (+1 reserved) breakpoint and 1 watchpoint registers.

hw-breakpoint: maximum watchpoint size is 4 bytes.

zynq-ocm f800c000.ps7-ocm: ZYNQ OCM pool: 256 KiB @ 0xe0880000

SCSI subsystem initialized

usbcore: registered new interface driver usbfs

usbcore: registered new interface driver hub

usbcore: registered new device driver usb

media: Linux media interface: v0.10

Linux video capture interface: v2.00

EDAC MC: Ver: 3.0.0

Advanced Linux Sound Architecture Driver Initialized.

Switched to clocksource ttc_clocksource

NET: Registered protocol family 2

TCP established hash table entries: 4096 (order: 2, 16384 bytes)

TCP bind hash table entries: 4096 (order: 3, 32768 bytes)

TCP: Hash tables configured (established 4096 bind 4096)

TCP: reno registered

UDP hash table entries: 256 (order: 1, 8192 bytes)

UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)

NET: Registered protocol family 1

hw perfevents: enabled with armv7_cortex_a9 PMU driver, 7 counters available

futex hash table entries: 512 (order: 3, 32768 bytes)

io scheduler noop registered

io scheduler deadline registered

io scheduler cfq registered (default)

dma-pl330 f8003000.ps7-dma: Loaded driver for PL330 DMAC-241330

dma-pl330 f8003000.ps7-dma:     DBUFF-128x8bytes Num_Chans-8 Num_Peri-4 Num_Events-16

e0001000.uart: ttyPS0 at MMIO 0xe0001000 (irq = 20, base_baud = 3125000) is a xuartps

�console [ttyPS0] enabled

console [ttyPS0] enabled

bootconsole [earlycon0] disabled

bootconsole [earlycon0] disabled

xdevcfg f8007000.devcfg: ioremap 0xf8007000 to e081a000

[drm] Initialized drm 1.1.0 20060810

drivers/gpu/drm/adi_axi_hdmi/axi_hdmi_drv.c:axi_hdmi_platform_probe[176]

platform 70e00000.axi_hdmi: Driver axi-hdmi requests probe deferral

brd: module loaded

loop: module loaded

m25p80 spi32766.0: found s25fl256s1, expected n25q128a11

m25p80 spi32766.0: s25fl256s1 (32768 Kbytes)

5 ofpart partitions found on MTD device spi32766.0

Creating 5 MTD partitions on "spi32766.0":

0x000000000000-0x000000500000 : "boot"

0x000000500000-0x000000520000 : "bootenv"

0x000000520000-0x000000540000 : "config"

0x000000540000-0x000000fc0000 : "image"

0x000000fc0000-0x000002000000 : "spare"

libphy: XEMACPS mii bus: probed

xemacps e000b000.eth: pdev->id -1, baseaddr 0xe000b000, irq 33

ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver

usbcore: registered new interface driver usb-storage

usbcore: registered new interface driver usbserial

usbcore: registered new interface driver usbserial_generic

usbserial: USB Serial support registered for generic

usbcore: registered new interface driver ftdi_sio

usbserial: USB Serial support registered for FTDI USB Serial Device

e0002000.usb supply vbus not found, using dummy regulator

ULPI transceiver vendor/product ID 0x0451/0x1507

Found TI TUSB1210 ULPI transceiver.

ULPI integrity check: passed.

mousedev: PS/2 mouse device common for all mice

i2c /dev entries driver

zynq-edac f8006000.ps7-ddrc: ecc not enabled

Xilinx Zynq CpuIdle Driver started

Driver 'mmcblk' needs updating - please use bus_type methods

sdhci: Secure Digital Host Controller Interface driver

sdhci: Copyright(c) Pierre Ossman

sdhci-pltfm: SDHCI platform and OF driver helper

sdhci-arasan e0100000.sdhci: No vmmc regulator found

sdhci-arasan e0100000.sdhci: No vqmmc regulator found

mmc0: SDHCI controller on e0100000.sdhci [e0100000.sdhci] using ADMA

ledtrig-cpu: registered to indicate activity on CPUs

hidraw: raw HID events driver (C) Jiri Kosina

usbcore: registered new interface driver usbhid

usbhid: USB HID core driver

adv7511-hdmi-snd fpga-axi@0:adv7511_hdmi_snd: adv7511 <-> 75c00000.axi-spdif-tx mapping ok

mmc0: new high speed SDHC card at address 0007

mmcblk0: mmc0:0007 SD04G 3.70 GiB

mmcblk0: p1 p2

zed-adau1761-snd fpga-axi@0:zed_sound: adau-hifi <-> 77600000.axi-i2s mapping ok

TCP: cubic registered

NET: Registered protocol family 17

Registering SWP/SWPB emulation handler

Console: switching to colour frame buffer device 128x48

axi-hdmi 70e00000.axi_hdmi: fb0:  frame buffer device

axi-hdmi 70e00000.axi_hdmi: registered panic notifier

[drm] Initialized axi_hdmi_drm 1.0.0 20120930 on minor 0

drivers/rtc/hctosys.c: unable to open rtc device (rtc0)

ALSA device list:

  #0: HDMI monitor

  #1: ZED ADAU1761

EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)

VFS: Mounted root (ext4 filesystem) on device 179:2.

devtmpfs: mounted

Freeing unused kernel memory: 208K (c05ee000 - c0622000)

+ Ǫ�ɕ�������j�����ɽ����Bͺ��J ʢ��ɵ����ѕ����ѡ��х���Ѫ�vailable

Last login: Thu Jan  1 00:01:23 UTC 1970 on ttyPS0

 

Login timed out after 60 seconds.

 

Last login: Thu Jan  1 00:00:08 UTC 1970 on tty1

cat: /var/lib/update-notifier/fsck-at-reboot: No such file or directory

run-parts: /etc/update-motd.d/98-fsck-at-reboot exited with return code 1

Welcome to Linaro 12.11 (GNU/Linux 3.19.0-g5b0956e armv7l)

 

* Documentation:  https://wiki.linaro.org/

 

0 packages can be updated.

0 updates are security updates.

 

root@linaro-ubuntu-desktop:~#

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

This problem has bothered me for a long time.

I wish someone can help figure this out.

 

Thanks,

Yao Liu

Outcomes