2 Replies Latest reply: Feb 1, 2011 10:23 AM by amardeepd RSS

    gmake-378 no rule to make target problem


      Hi all;


      I am having a problem running a build of a project. It had been building fine and I was working through the errors re-building every one or two to ensure that I had fixed the issues. I had just commented out a break (I had commented out the case switch for a previous fix and forgot to comment out the break... doh!) and then I started getting the following error:


      ----------------Configuration: coreA - Debug----------------

      C:\Program Files\Analog Devices\VisualDSP 5.0\gmake-378: *** No rule to make target `####################', needed by `Debug/coreA.doj'.  Stop.
      No valid command(s) to build.
      Build was unsuccessful.


      I undid the last couple of fixes I had done even though I knew it had built fine in-between but I am still getting the error. I have tried to touch the installation and to check if there was a second gmake in the directory without an extention (which was someone elses problem) but to no avail. The error is coming up with all of my projects now but its not always for the coreA.doj (different projects have it stating a different needed by).


      Any ideas?



        • 1. Re: gmake-378 no rule to make target problem

          Hi Amar,


          The "No Rule to Make Target" error can be a tricky one to track down, but it is ultimately caused by a reference in your makefile to a non existent file. The problem can be that it doesn't necessarily have to be an actual filename causing the problem; it could be a corrupt command line in the makefile.


          The first place to look is the makefile itself, to try and track where the error is actually coming from; find any references to the filename, and ensure that these commands are correctly formatted.


          Next you should check the files/directories that these commands are referencing; do they actually exist? If the files do exist, are they in the location the command line is looking, or are they elsewhere?


          You should next check your project options. Ensure that all 'Search Directories' for the Linker, and 'Additional Include Directories' for the Compiler/Assembler are configured correctly. If any of your paths or filenames are wrapped in quotes, ensure that they have both a closing and opening quote, as this can cause problems with the makefile.


          The last place to check is the LDF. If you have made any modifications, make sure they were made within $VDSG sections, or they will have been deleted when the LDF was regenerated. Ensure any libraries referenced in the LDF exist, with the correct filename, and that the directory they are in - if not a standard directory - is included in the search directory.


          Something else you can try, to determine if the problem is Project Option related, is to switch to another configuration (e.g. switch to Release) and see if that builds.


          Do the BF561 example projects, located in "...\Blackfin\Examples\ADSP-BF561 EZ-KIT Lite" compile correctly?


          If you are still unable to track the cause, we will likely need to take a closer look at your project in order to provide anything other than general advice. If you prefer not to post the code on the forum you can contact us through private support:





          • 2. Re: gmake-378 no rule to make target problem

            Thanks Craig,


            It worked a treat. Turned out to be both the makefile reference and the LDF reference. I hadn't edited either manually but I guess it was a small glitch.