AnsweredAssumed Answered

ADZS-HPUSB-ICE worked yesterday but not today

Question asked by jhenders on Jan 25, 2011
Latest reply on May 30, 2012 by mceleste

I have been using the same setup for months now:

 

Product Name:  VisualDSP++ 5.0 Update 8
Product Version:  5.0.8.0

IDDE Version:  8.0.7.5
IDDE Build Date:  Mar 21 2010
Installation Directory:  C:\Program Files\Analog Devices\VisualDSP 5.0
Operating System:  Microsoft Windows XP
OS Version:  5.1 Service Pack 3 (Build 2600)

 

Target: Custom board with SHARC 21469.

 

Problem:

Up until yesterday everything worked as expected, I was able to create sessions, connect, and load and execute DSP images. Now after the weekend I plugged everything back in and powered it up and I am getting this message:

 

Error code: 0x80048049
Error description: Failed detecting number of device connected.

 

Sometimes it will also have a first message stating that it could not detect the firmware version and to power cycle everything, followed by the message above.

 

If I run an ICE Test with defaults:


Type: HPUSB-ICE
Device ID: 0
JTAG I/O VOltage: 3.3/5
JTAG TCLK Frequency: 10

 

It fails at Opening Emulator Interface with comment "Could not open emulator interface. Check driver and I/O settings."

 

Things I have tried to remedy: Using different DSP board, different USB ports, uninstalling/reinstalling USB drivers, power cycling everything including the PC, removing all USB connections except for the HPUSB emulator. All were unsuccessful, with the same error code given.

 

Also related: I can connect to a 21369 EZ-Kit just fine.

 

This was working just fine before! Thanks for your attention.

Outcomes