AnsweredAssumed Answered

ADuC7026 Serial download problem

Question asked by Andrew on Jan 17, 2011
Latest reply on Jan 22, 2011 by Andrew

Hi,

 

I'm working with the ADuC7026 and I'm experiencing problems when I try to download firmware through the UART. I'm using the ARMWSD tool and when I try to download the hex file (clicking start and then following the button sequence detailed in AN-724), it fails with the error "<something> received.Waiting for correct ID string.", where <something> seems to be trash. I tried different bauds but the problem is still there.

 

I tried to start the download mode using an Hyperterminal like software (Docklight), I mean, I configured the serial port in 8 bits no parity, I followed the same button sequence, and then I sent the backspace (0x08) character. The result was always the same: the Hyperterminal received trash, sometimes non-printable characeters, sometimes the start of the 24 byte ID data packet (eg. ADuC7.. and then trash), it depends on the baud rate but is not always the same sequence for the same baud rate (for the same baudrate different trash sequences are received each time I repeat the steps, but for some baudrates only nulls are received). I tested baud rates as low as 600 bps and as high as 115200 bps.

 

I first thought that the problem was in my MAX3232 home made interface, but I tested it in loopback mode (just joining together the input and output pins in the logic side) and it worked fine (ie. it echoed OK every sequence I sent).

 

I discarded also BM or RESET problems, due to the fact that sometimes the firsts bytes of the ID sequence are received, so I understand that the programming mode is entered and the device is reset, but something happens after this that corrupts part of or all the ID sequence.

 

Before I try with a second protoype, I would like another opinion, maybe I'm doing something wrong. I would appreciate any help you could give me.

 

Thanks in advance,
Andrew.

Outcomes