AnsweredAssumed Answered

FMCOMMS5 and gnuradio-companion

Question asked by wahall on May 8, 2015
Latest reply on Jul 21, 2015 by SMiles
Branched to a new discussion

I am using an FMCOMMS5 EVB and ZC702 with the SD card built per Wiki instructions and am able to successfully run IIO Oscilloscope.  I then close IIO Oscilloscope and start gnuradio-companion while root.  The fmradio example gives me the following error dialog:

 

Generating: "/home/analog/Desktop/gnuradio-examples/top_block.py"
>>> Warning: This flow graph may not have flow control: no audio or usrp blocks found. Add a Misc->Throttle block to your flow graph to avoid CPU congestion.

Executing: "/home/analog/Desktop/gnuradio-examples/top_block.py"

Fontconfig warning: ignoring C.UTF-8: not a valid language tag
Using Volk machine: neon_hardfp
Traceback (most recent call last):
   File "/home/analog/Desktop/gnuradio-examples/top_block.py", line 131, in <module>
     tb = top_block(decimation=options.decimation, audiodevice=options.audiodevice, hostname=options.hostname)
   File "/home/analog/Desktop/gnuradio-examples/top_block.py", line 54, in __init__
     self.iio_fmcomms2_source_0 = iio.fmcomms2_source(hostname, fm_station, 1536000, decimation - 1, 20000000, True, True, False, False, 0x20000, True, True, True, "slow_attack", 64.0, "slow_attack", 64.0, "A_BALANCED")
   File "/usr/lib/python2.7/dist-packages/gnuradio/iio/iio_swig.py", line 166, in make
     return _iio_swig.fmcomms2_source_make(*args, **kwargs)
RuntimeError: Device not found

>>> Done

I am able to successfully run gnuradio projects that use a noise source block in place of the FMCOMMS2 source.  I am also able to run gnuradio projects using the FMCOMMS2 source and an FMCOMMS2 EVB using the appropriate files copied to boot level on the SD card.  What could be different about using the FMCOMMS5 EVB and I am missing?

Thank you.

 

Outcomes