AnsweredAssumed Answered

I2C can't communication for ADAU1761

Question asked by carlos777 on Apr 13, 2015
Latest reply on Apr 15, 2015 by carlos777

Hi Guys,

Sorry to describe my issue by pool English.

 

I using ADAU1761 to design an audio functional PCB.
Basically I follow the demo board schematic to design my PCB.

I got PCB and solder components last week.

 

But when I using USBi download my project to ADAU1761,
SigmaStudio show USB communication failed.

 

I checked the waveform for SCL and SDA,
find ADAU1761 had no ACK to USBi(Address Byte).


I checked my PCB and schematic,
1.My PCB is work at 1.8V and powered via power supply.
2.The pin define for ADAU1761 is the same to datasheet.

3.CM pin's voltage the same as demo board is 0.9V

4.The VDDOUT voltage is 1.55V, it's the same as demo board.
5.ADDR0 and ADDR1 set to '0'(Connect to GND by 0 ohm).

6.CM and VDDOUT pin placed 0.1u and 22uF to decouped.

7.The 12.288MHz OSC work well and send the signal to MCLK pin.

8.Etch Pin  for power and GND does not short.

9.The pull up resister set to 1.8k.

10.SCL and SDA pin does not short or open between pin and USBi.

11.Connect SCL, SDA and GND from USBi to my PCB.

12.USBi set IOVDD Switch to 1.8V.

 

After I checked the above item and re-check the SCL and SDA waveform,
ADAU1761 still had no ACK to USBi.

 

Finally,
I changed the ADAU1761,

But still no ACK...

Maybe my soldering technique too pool.

I connect the SMD manufacture and using reflow to solder the ADAU1761,

but I2C still no ACK to USBi.

 

I have no idea which condition i miss let ADAU1761 I2C does not work normally??

Does every body have any suggest for me?

 

Best regards,
Carlos Lin

Outcomes