AnsweredAssumed Answered

AD9361 Linux kernel compatible with 3.14.0?

Question asked by daniel.nauth Employee on Apr 7, 2015
Latest reply on May 15, 2015 by ligang23090

We need to add AD9361 device driver support and iio driver support the Linux kernel using by following the instructions in this link:

http://wiki.analog.com/resources/tools-software/linux-drivers/iio-transceiver/ad9361

We are using a kernel and u-boot based on the Vivado 2014.2 release (https://github.com/Xilinx/linux-xlnx/tree/xilinx-v2014.2,
https://github.com/Xilinx/u-boot-xlnx/tree/xilinx-v2014.2)

 

It appears existing AD0361 driver support is based on kernel 3.18.0 (https://github.com/analogdevicesinc/linux/tree/xcomm_zynq). Is this correct? And if so, will we have trouble adding AD9361 driver support into 3.14.0?

 

Thanks!

Outcomes