AnsweredAssumed Answered

Executable Fails to Download to Target After Build in Debug Mode

Question asked by spflanze on Apr 1, 2015
Latest reply on Apr 3, 2015 by spflanze

There is a circuit board based on an ADSP-BF547 that used to work, but now has problems. The firmware seems to run, but the measurements it makes are not the same. So I have attached the ADZS-USB-ICE emulator probe to the boards JTAG to step through code and find out why.

 

The way it worked before is I connected to the target using Session => Connect to Target. Then I build the project. Once built it would automatically download the executable into the target's ram, and if in debug mode, automatically set a breakpoint on the first line of code, and pause there. But this does not happen anymore. After building there is no sign that it is downloading an executable. It ignores the breakpoints I manually set. When I do debug run it halts at an illegal opcode of 0xEEEE.

 

Any suggestions to get this working are welcome.

 

Where can I verify the project is set to automatically download executable code to the target after a build?

 

No changes have been made to the project since it last worked.

Outcomes