AnsweredAssumed Answered

ADV7612 BITSTREAM audio problems

Question asked by MichaM on Mar 31, 2015
Latest reply on Apr 15, 2015 by mattp

Hello everyone,

 

I’m working on a project using the ADV7612 and i get some problems with it when using BITSTREAM output type with any players.

Source : OPPO BDP-103D

Sink : custom ADV7612 board

 

I use the configuration script “ADV7612-VER.2.9c_AVEB“ :

##EDID##

:ADV7612 EDID 12 bit Video, DSD and HBR AUDIO Enabled:

And

## HDMI-DSD Audio ADV7612 ##

 

We only use the ADV7612 for audio extraction :

OPPO 103D (or any other players) ==> ADV7612 (I2S or DSD signals) ==> DAC

 

  • When playing CD audio :

-when I set the HDMI audio output of the player to LPCM or BITSTREAM, on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are able to decode those signals, we got sound so there is no problem.

SPDIF0 is also working and when we use it with another device we got sound as well.

 

  • When playing DVD audio :

-when I set the HDMI audio output of the player to LPCM or BITSTREAM, the audio track playing is either “Dolby Digital 5.1” or “Advanced Resolution Stereo (192 kHz/24 bit)”, on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are able to decode those signals, we got sound so there is no problem.

SPDIF0 is also working and when we use it with another device we got sound as well.

 

  • When playing Blu-Ray movies :

-when I set the HDMI audio output of the player to “LPCM”, the audio track playing is “Dolby TrueHD” on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are able to decode those signals, so there is no problem.

SPDIF0 is also working and when we use it with another device we got sound.

 

-when I set the HDMI audio output of the player to “BITSTREAM”, the audio track playing is “Dolby TrueHD”, on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we only get MCLK, LRCLK and SCLK signals. There is nothing on I2S0.

SPDIF0 is not working and when we use it with another device there is no sound.

Is it normal that there are nothing on SPDIF0 and I2S0 ?

 

  • When playing Blu-Ray PURE AUDIO :

-when I set the HDMI audio output of the player to “LPCM”, the audio track playing is either “DTS HD master audio” or “LPCM”, on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are able to decode those signals, so there is no problem.

SPDIF0 is also working and when we use it with another device we got sound.

 

-when I set the HDMI audio output of the player to “BITSTREAM”, the audio track playing is “PCM”, on the ADV7612 we get AUDIO_SAMPLE_PCKT_DET, Addr 68 (HDMI), Address 0x18[0] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are able to decode those signals, so there is no problem.

SPDIF0 is also working and when we use it with another device we got sound.

 

-when I set the HDMI audio output of the player to “BITSTREAM”, the audio track playing is “DTS HD master audio”, on the ADV7612 we get HBR_AUDIO_PCKT_DET, Addr 68 (HDMI), Address 0x18[3] to “1” and we get MCLK, LRCLK, SCLK and I2S0 signals.

Our DAC are unable to decode those signals, we got “machine gun” sound.

There is a signal on SPDIF0 but when we use it with another device we also got the “machine gun” sound.

Is it normal ? Do we have to use I2S1, I2S2 and I2S3 ?

We only need stereo sound.

 

Sorry for this long post, but I wanted to be clear about our problems.

I hope you understand.

 

Thank you.

Outcomes