AnsweredAssumed Answered

What Xilinx Vivado software version for designs on GitHub?

Question asked by nickh_xfae on Mar 26, 2015
Latest reply on Mar 26, 2015 by rejeesh

Hello All;

 

I have downloaded the GitHub FPGA HDL designs, I am particularly interested in the ADV7511 design running on a Xilinx A701 board under some version of Vivado.

 

It is not clear to me which version of Vivado I should be using.  I have tried 2014.4, it errors on a MicroBlaze version.

 

Some research seemed to suggest that Vivado 2013.4 was the right version however when I try to run the system_project.tcl script from 2013.4 Vivado tcl console.I get:

 

ERROR: [BD 5-216] VLNV <analog.com:user:axi_clkgen:1.0> is not supported for thi

s version of the tools

ERROR: [Common 17-39] 'create_bd_cell' failed due to earlier errors.

 

 

 

 

  It is mentioned in readme.md that Vivado 2014.2 should be used.  When running that I get the same Microblaze version error as 2014.4 :

ERROR: [BD 5-216] VLNV <xilinx.com:ip:microblaze:9.2> is not supported for this

version of the tools.The latest version is:9.3

ERROR: [Common 17-39] 'create_bd_cell' failed due to earlier errors.

 

 

I cannot figure out which version to use that will build.  Can someone help me out?

 

Thanks

Nick

Outcomes