AnsweredAssumed Answered

GRC questions

Question asked by rgetz Employee on Mar 25, 2015
Latest reply on Mar 31, 2015 by rgetz

Someone asked me by email:

 

--------------------

 

For the last few days I have been working on the Zynq706 with FMCOMMS-3 board to get a simple GRC model running. The installation of GNURadio is now complete and I can run GRC on it, however I had the following observations/questions

 

  • I could only find FMCOMMS-2 sink and source blocks in GRC.
  • Using FMCOMMS-2 GRC block where S-3 board is actually being used, I can execute the model with no error but the model automatically stops in a few seconds while no output is being generated (As a test, I tried to hook up the block to an FFT spectrum analyzer).
  • Looking into ADI datasheets it seems like, S2 and S3 are similar architecture-wise, but it seems like S-3 is not currently supported (I tried verifying this by putting some printfs in fmcomms2-souce_impl.cc code).
  • For the current test I had to install GNURadio from source, though the ADI's Zynq Quick Start Guide page says, newer version of the SD card pre-built images provided by ADI have GNURadio pre-installed. I updated my SD card with these newer images, but then the board didn't boot up (I tried both 2014 and 2015 releases in this page: http://wiki.analog.com/resources/tools-software/linux-software/zynq_images , but both attempts were unsuccessful).
  • The tools to update the images assume an 8GB SD card. Is there a way to use a larger SD like 32GB?

 

--------------

Outcomes