AnsweredAssumed Answered

ADV8005 - Unable to get output on TX1?

Question asked by James-Intrinsyc on Mar 16, 2015
Latest reply on May 29, 2015 by James-Intrinsyc

I have VSP 1.90Rel, and it's been ported to my platform (Android on ARM) as we have an ADV7619+ADV8005 on the board. TX1 hooks straight to a HDMI-to-MIPI bridge that we've used before (previous revisions of our board didn't have the ADV chips on them - the HDMI input of the bridge was brought straight out).

 

We did find a small error in our layout (the HPD input of the 8005 and the HPD-In of our bridge were wired together, instead of the HPD-Out of the bridge being wired to the HPD input of the 8005). This we remedied temporarily by wiring both to +5V external power supply.

 

When the power supply is off (HPD low), we get the expected "Receiver" mode - we have a source on RX port A and it appears to work. When I bring HPD high via the supply we see messages indicating the HPD line was brought high, and it appears everything is OK, except we don't have TMDS output.

 

Output follows.

 

Start up VSP with a source connected to Port A on the 7619:

 

shell@msm8974:/ # adi_vsp

 

 

Advantiv Video Evaluation Board Software Version: 1.6

Starting Repeater on Boot ...

HAL_PlatformInit: Reset ADV7619

adv7619_reset: returning 0

HAL_PlatformInit: Reset ADV8005

adv8005_reset: returning 0

HAL_PlatformInit: Init success

HAL_GetHwRevision

 

********************************************************************

  ADI VSP AVR Application Ver V1.90.2

  PLATFORM: EVAL-ADV8005-SMZ

  HDMI-RX:  ADV7619 Rev 0x20c1

  HDMI-TX:  ADV8005 Rev 0x6083 without Rovi

  Created:  Mar 16 2015 At 15:34:56

********************************************************************

 

HAL_GetRxBoardRevision: Not implemented

HAL_GetTxBoardRevision: Not implemented

-Rx: 34:366 Configuring RX CSC:   RGB 444 --> RGB 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 34:370 Free-run CS is set to RGB

HAL_PlatformRXInit: Not implemented

-T1: 34:377 #### Muted using: TMDS ASP (TX PLL not locked)

-T1: 34:399 Setting audio parameters:

             SF=32 KHz  CC=2  HBR=No

HAL_EnableTxHPD: Not implemented

HAL_PlatformTXInit: Not implemented

-T2: 35:125 #### Muted using: TMDS ASP (TX PLL not locked)

-T2: 35:147 Setting audio parameters:

             SF=32 KHz  CC=2  HBR=No

HAL_EnableTxHPD: Not implemented

HAL_PlatformTXInit: Not implemented

HAL_EnableHDMIPath: Not implemented

-Rx: 35:833 @@@@ RX Mute State changed to 2

APP: Setting port A HPD and CLK TERM to LOW.

            TX1 from OSD

            TX2 from OSD

            Component from OSD

            CVBS & S-Video from OSD

-VP: 36:205 Starting bytes/pixel for Vsp1=4   Vsp2=4

-VP: 36:206 VSP1 Bandwidth = 0.00 GB/s

-VP: 36:206 VSP2 Bandwidth = 0.00 GB/s

-VP: 36:206 Comb Bandwidth = 0.00 GB/s

-VP: 36:206 Total Bandwidth (With OSD) = 0.88 GB/s

-VP: 36:209 OSD  pass-through -->TX1

            TX1 from OSD

-VP: 36:210 OSD  pass-through -->TX2

            TX2 from OSD

-VP: 36:211 OSD  pass-through -->Component

            Component from OSD

-VP: 36:216 OSD  pass-through -->CVBS

            CVBS & S-Video from OSD

-VP: 36:229 Sending AVI to TX1:

            00 02 00 00 00 00 00 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Full range

            PixelRep=0  Aspect=no data  Vic=0 (0)

-VP: 36:240 sending VS Infoframe without 4K or 3D info

-VP: 36:249 Sending VS Infoframe to TX1:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 36:257 Sending AVI to TX2:

            00 02 00 00 00 00 00 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Full range

            PixelRep=0  Aspect=no data  Vic=0 (0)

-VP: 36:268 sending VS Infoframe without 4K or 3D info

-VP: 36:276 Sending VS Infoframe to TX2:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

APP: Fast switching Disabled for all ports

-VP: 36:697 Vsp App: HDMI Input video is detected

-VP: 36:704 Input AVI is YUV. No CSC.

-VP: 36:713 Sending AVI to TX1:

            82 02 0d 00 58 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 36:731 Same AVI received. Input is YUV

-VP: 36:742 Sending AVI to TX2:

            82 02 0d 00 58 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 36:755 Detected video:

             Vic   = 2

             Format= 720x480p60

             H-Pol = -ve

             V-Pol = -ve

             VfmPer= 0xc00d544b

-VP: 36:811 Starting bytes/pixel for Vsp1=4   Vsp2=4

-VP: 36:811 VSP1 Bandwidth = 0.00 GB/s

-VP: 36:811 VSP2 Bandwidth = 0.00 GB/s

-VP: 36:811 Comb Bandwidth = 0.00 GB/s

-VP: 36:811 Total Bandwidth (With OSD) = 0.88 GB/s

-VP: 36:814 OSD  pass-through -->TX1

            TX1 from OSD

-VP: 36:815 OSD  pass-through -->TX2

            TX2 from OSD

-VP: 36:815 OSD  pass-through -->Component

            Component from OSD

-VP: 36:819 OSD  pass-through -->CVBS

            CVBS & S-Video from OSD

-VP: 36:830 Sending AVI to TX1:

            82 02 0d 00 58 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 36:841 sending VS Infoframe without 4K or 3D info

-VP: 36:850 Sending VS Infoframe to TX1:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 36:862 Sending AVI to TX2:

            82 02 0d 00 58 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 36:874 sending VS Infoframe without 4K or 3D info

-VP: 36:881 Sending VS Infoframe to TX2:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 36:881 Vsp App: Input Video Frequency = 27MHz

APP: RX EDID is ready to be accessed now.

-Rx: 36:910 TMDS Clock NOT detected on selected port (A)

-Rx: 36:912 Configuring RX CSC:   RGB 444 --> RGB 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 36:916 Free-run CS is set to RGB

-Rx: 36:919 Source signal changed to DVI

APP: SOURCE is DVI

-Rx: 36:920 Received AVI Info Frame (RAW) Packet:

             02 02 0d 00 08 00 02 00   00 00 00 00 00 00 00 00

-Rx: 36:921 Received AVI Info Frame Packet:

             02 02 0d 00 08 00 02 00   00 00 00 00 00 00 00 00

             VIC = 2 (720x480p @ 60Hz)

             Colorspace = RGB    PR = 0    Picture Aspect Ratio: no data

-Rx: 36:923 Configuring RX CSC:   RGB 444 --> RGB 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 36:926 Free-run CS is set to RGB

-VP: 36:943 Input AVI is RGB. Converting to YUV 601.

-VP: 36:954 Sending AVI to TX1:

            02 02 0d 00 08 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=no data  Vic=2 (720x480p @ 60Hz)

-VP: 36:968 Same AVI received. Input is RGB

-VP: 36:978 Sending AVI to TX2:

            02 02 0d 00 08 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=no data  Vic=2 (720x480p @ 60Hz)

APP: Setting all ports HPD to HI.

-T1: 37:014 HPD changed to LOW

-T1: 37:019 #### Muted using: TMDS ASP (TX PLL not locked)

-T1: 37:040 Setting audio parameters:

             SF=32 KHz  CC=2  HBR=No

-VP: 37:046 Combined EDID reset. All TX HPDs are low

-T1: 37:046 ### An empty EDID was received due to HPD = 0    ###

-T1: 37:046 ### This is the EDID modified by the application ###

------------------------- EDID BLOCK 0 -------------------------

Edid Version 1.3

Mon Timing:

    Pixel clock = 148.50 MHz

    H Active    = 1920

    V Active    = 1080

    Progressive

    No stereo

    Separate sync = 3

    +ve VSync

    +ve HSync

Mon Timing:

    Pixel clock = 74.25 MHz

    H Active    = 1920

    V Active    = 540

    Interlaced

    No stereo

    Separate sync = 3

    +ve VSync

    +ve HSync

Mon Name:   ADI ADV800X

Mon Freq:

    Min V Freq = 29 Hz

    Max V Freq = 86 Hz

    Min H Freq = 15 KHz

    Max H Freq = 111 KHz

Edid extensions blocks: 1

 

========================= EDID BLOCK 1 =========================

CEA extension block revision 3

Underscan=Yes  Audio=Yes  YCbCr4:4:4=Yes  YCbCr4:2:2=Yes

Data block collection information:

    Video data block

       * VIC=16

         VIC=4

         VIC=3

         VIC=18

         VIC=1

         VIC=19

         VIC=17

         VIC=7

         VIC=5

         VIC=6

         VIC=34

         VIC=20

         VIC=21

    Audio data block

       Format Code          = 1 (Linear PCM)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 32  44.1  48  88.2  96  176.4  192

        Length (bits)       = 16  20  24

       Format Code          = 2 (AC-3)

        Max. No. of Channels= 6

        Sampling Freq. (KHz)= 32  44.1  48

        Max. Bit Rate       = 640 KHz

       Format Code          = 7 (DTS)

        Max. No. of Channels= 7

        Sampling Freq. (KHz)= 32  44.1  48  88.2  96

        Max. Bit Rate       = 1536 KHz

       Format Code          = 9 (One Bit Audio)

        Max. No. of Channels= 6

        Sampling Freq. (KHz)= 44.1

       Format Code          = 10 (Dolby Digital +)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 44.1  48

       Format Code          = 12 (MAT(MLP))

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 48  96  192

       Format Code          = 11 (DTS-HD)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 48  96  192

        Vendor Code         = 1

    Speaker allocation data block

       0xff

       0x07

       0x00

    VSDB data block

       30-bit Deep color (RGB)

       36-bit Deep color (RGB)

       48-bit Deep color (RGB)

       YCbCr Deep color supported

       Max TMDS clock = 300 MHz

       3D_present = 1, 3D_multi_present = 0, HDMI_VIC_LEN = 4, HDMI_3D_LEN = 0

       HDMI Sink supports 3D  with only mandatory 3D formats

       HDMI_VIC_1  = 0x1

       HDMI_VIC_2  = 0x2

       HDMI_VIC_3  = 0x3

       HDMI_VIC_4  = 0x4

    Extended Tag data block

       Extended tag code is 14

       YCbCr 4:2:0 Video Data Block (Y420VDB)

          VIC=96

          VIC=97

          VIC=101

          VIC=102

          VIC=106

          VIC=107

SPA location is at 0xb0, SPA = 1.0.0.0

Mon Timing:

    Pixel clock = 274.98 MHz

    H Active    = 1

    V Active    = 3442

    Progressive

    No stereo

    Separate sync = 0

    -ve Vsync

    -ve HSync

########################### EDID END ###########################

 

APP: EDID received. Setting all ports HPD to LOW.

APP: My phys address is  1.0.0.0

APP: Port 0 Phys Addr is 1.1.0.0

APP: Port 1 Phys Addr is 1.2.0.0

APP: Writing EDID segment 0 to Rx...

-T1: 37:121 MSEN changed to HI

APP: re-send Received AVI, VS and Audio Packets

-VP: 37:143 Input AVI is RGB. Converting to YUV 601.

-VP: 37:153 Sending AVI to TX1:

            00 02 00 00 00 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=no data  Vic=2 (720x480p @ 60Hz)

-VP: 37:185 Input AVI is RGB. Converting to YUV 601.

-VP: 37:197 Sending AVI to TX1:

            02 02 0d 00 08 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=no data  Vic=2 (720x480p @ 60Hz)

-T2: 37:220 HPD changed to LOW

-T2: 37:224 #### Muted using: TMDS ASP (TX PLL not locked)

-T2: 37:246 Setting audio parameters:

             SF=32 KHz  CC=2  HBR=No

-VP: 37:250 Combined EDID reset. All TX HPDs are low

-T2: 37:250 ### An empty EDID was received due to HPD = 0    ###

-T2: 37:250 ### This is the EDID modified by the application ###

------------------------- EDID BLOCK 0 -------------------------

Edid Version 1.3

Mon Timing:

    Pixel clock = 148.50 MHz

    H Active    = 1920

    V Active    = 1080

    Progressive

    No stereo

    Separate sync = 3

    +ve VSync

    +ve HSync

Mon Timing:

    Pixel clock = 74.25 MHz

    H Active    = 1920

    V Active    = 540

    Interlaced

    No stereo

    Separate sync = 3

    +ve VSync

    +ve HSync

Mon Name:   ADI ADV800X

Mon Freq:

    Min V Freq = 29 Hz

    Max V Freq = 86 Hz

    Min H Freq = 15 KHz

    Max H Freq = 111 KHz

Edid extensions blocks: 1

 

========================= EDID BLOCK 1 =========================

CEA extension block revision 3

Underscan=Yes  Audio=Yes  YCbCr4:4:4=Yes  YCbCr4:2:2=Yes

Data block collection information:

    Video data block

       * VIC=16

         VIC=4

         VIC=3

         VIC=18

         VIC=1

         VIC=19

         VIC=17

         VIC=7

         VIC=5

         VIC=6

         VIC=34

         VIC=20

         VIC=21

    Audio data block

       Format Code          = 1 (Linear PCM)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 32  44.1  48  88.2  96  176.4  192

        Length (bits)       = 16  20  24

       Format Code          = 2 (AC-3)

        Max. No. of Channels= 6

        Sampling Freq. (KHz)= 32  44.1  48

        Max. Bit Rate       = 640 KHz

       Format Code          = 7 (DTS)

        Max. No. of Channels= 7

        Sampling Freq. (KHz)= 32  44.1  48  88.2  96

        Max. Bit Rate       = 1536 KHz

       Format Code          = 9 (One Bit Audio)

        Max. No. of Channels= 6

        Sampling Freq. (KHz)= 44.1

       Format Code          = 10 (Dolby Digital +)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 44.1  48

       Format Code          = 12 (MAT(MLP))

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 48  96  192

       Format Code          = 11 (DTS-HD)

        Max. No. of Channels= 8

        Sampling Freq. (KHz)= 48  96  192

        Vendor Code         = 1

    Speaker allocation data block

       0xff

       0x07

       0x00

    VSDB data block

       30-bit Deep color (RGB)

       36-bit Deep color (RGB)

       48-bit Deep color (RGB)

       YCbCr Deep color supported

       Max TMDS clock = 300 MHz

       3D_present = 1, 3D_multi_present = 0, HDMI_VIC_LEN = 4, HDMI_3D_LEN = 0

       HDMI Sink supports 3D  with only mandatory 3D formats

       HDMI_VIC_1  = 0x1

       HDMI_VIC_2  = 0x2

       HDMI_VIC_3  = 0x3

       HDMI_VIC_4  = 0x4

    Extended Tag data block

       Extended tag code is 14

       YCbCr 4:2:0 Video Data Block (Y420VDB)

          VIC=96

          VIC=97

          VIC=101

          VIC=102

          VIC=106

          VIC=107

SPA location is at 0xb0, SPA = 1.0.0.0

Mon Timing:

    Pixel clock = 274.98 MHz

    H Active    = 1

    V Active    = 3442

    Progressive

    No stereo

    Separate sync = 0

    -ve Vsync

    -ve HSync

########################### EDID END ###########################

 

APP: EDID received. Setting all ports HPD to LOW.

APP: My phys address is  1.0.0.0

APP: Port 0 Phys Addr is 1.1.0.0

APP: Port 1 Phys Addr is 1.2.0.0

APP: Writing EDID segment 0 to Rx...

-T2: 37:658 MSEN changed to LOW

APP: Changed system mode to Receiver

APP: Freerun is ON. VIC is 2

-Rx: 37:738 @@@@ RX entering free-run

-Rx: 37:739 @@@@ RX started delay to unmute

-Rx: 37:748 Free-run CS is set to RGB

APP: Sending free-run AVI with Vic=2, CS=RGB

-VP: 37:767 Input AVI is RGB. Converting to YUV 601.

-VP: 37:779 Sending AVI to TX1:

            82 02 0d 10 18 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 37:818 Same AVI received. Input is RGB

-VP: 37:828 Sending AVI to TX2:

            82 02 0d 10 18 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-Rx: 37:863 Configuring RX CSC:   RGB 444 --> RGB 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 37:866 Free-run CS is set to RGB

-Rx: 37:868 @@@@ RX Mute State changed to 0

-Rx: 37:877 @@@@ RX unmute delay expired

-Rx: 37:884 ----------> Int: Port A TMDS=0   1

-Rx: 37:884 ----------> Int: Intern Mute=1

-Rx: 37:885 ----------> Int: Port A PLL=0   1

-Rx: 37:893 ----------> Int: DE REGEN=0

-Rx: 37:894 ----------> Int: STDI Valid=0

APP: RX EDID is ready to be accessed now.

-Rx: 37:912 TMDS Clock NOT detected on selected port (A)

-Rx: 37:913 Selected Port is (Gear): A

-Rx: 37:913 Video PLL LCK change on Port (Gear): A

-Rx: 37:913 Video PLL Not Locked Port A

-Rx: 37:913 Internal Mute On

APP: Setting all ports HPD to HI.

-Rx: 39:560 ----------> Int: Port A TMDS=1   1

-Rx: 39:560 ----------> Int: Intern Mute=0

-Rx: 39:561 ----------> Int: Port A PLL=1   1

-Rx: 39:561 ----------> Int: AV mute=0

-Rx: 39:562 ----------> Int: DE REGEN=1

-Rx: 39:566 ----------> Int: AVI+

-Rx: 39:571 ----------> Int: AIF+

-Rx: 39:572 ----------> Int: HDMI=1

-Rx: 39:573 ----------> Int: FIFO_NEARUFLO=1

-Rx: 39:575 ----------> Int: Aud N Change

-Rx: 39:593 Bcaps/Bstatus changed. Hdcp reset required

-Rx: 39:598 HDCP setting change: BCAPS=0x80  Bstatus=0x0

-Rx: 39:608 TMDS Clock detected on selected port (A)

-Rx: 39:623 @@@@ RX Mute State changed to 2

-Rx: 39:630 @@@@ RX exiting free-run

-Rx: 39:631 Free-run CS is set to RGB

APP: Freerun is OFF

-Rx: 39:635 Selected Port is (Gear): A

-Rx: 39:635 Video PLL LCK change on Port (Gear): A

-Rx: 39:635 Video PLL Locked Port A

APP: Changed system mode to Repeater

-Rx: 39:667 Free-run CS is set to RGB

APP: Freerun is OFF

-Rx: 39:767 *******Default Eq Settings

-Rx: 39:772 Source signal changed to HDMI

APP: SOURCE is HDMI

-Rx: 39:772 AV Mute Off

-Rx: 39:772 Internal Mute Off

-Rx: 39:772 Received AVI Info Frame (RAW) Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

-Rx: 39:773 Received AVI Info Frame Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

             VIC = 5 (1920x1080i @ 60Hz)

             Colorspace = YCbCr 4:4:4    PR = 0    Picture Aspect Ratio: 16:9

-Rx: 39:778 Configuring RX CSC:   YCbCr 444 --> YCbCr 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 39:782 Free-run CS is set to YUV

-VP: 39:788 Input AVI is YUV. No CSC.

-VP: 39:797 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 39:813 Same AVI received. Input is YUV

-VP: 39:826 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-Rx: 39:848 Channel Status: Not valid. N=6144

-Rx: 39:854 Received Audio Info Frame Packet:

             84 01 0a 01 00 00 00 00   00 00 00 00 00

-Rx: 39:882 Channel Status: Not valid. N=6144

-Rx: 39:954 ----------> Int: Intern Mute=0

-Rx: 39:956 ----------> Int: V Lock=1

-Rx: 39:961 ----------> Int: Aud N Change

-Rx: 39:962 ----------> Int: FIFO_NEARUFLO=1

-Rx: 39:966 ----------> Int: STDI Valid=1

-Rx: 39:967 @@@@ RX started delay to unmute

-Rx: 39:986 @@@@ RX started delay to unmute

-Rx: 40:000 Bcaps/Bstatus changed. Hdcp reset required

-Rx: 40:000 Resetting HDCP by turning HPD low on all ports

-Rx: 40:009 HDCP setting change: BCAPS=0xc0  Bstatus=0x101

-Rx: 40:056 Internal Mute Off

-Rx: 40:058 @@@@ RX Mute State changed to 0

-Rx: 40:063 ----------> Int: AIF-

-Rx: 40:066 ----------> Int: AVI-

-Rx: 40:070 @@@@ RX unmute delay expired

-Rx: 40:089 Channel Status: Not valid. N=6144

-Rx: 40:167 ----------> Int: AVI+

-Rx: 40:173 ----------> Int: AIF+

-Rx: 40:195 Received AVI Info Frame (RAW) Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

-Rx: 40:196 Received AVI Info Frame Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

             VIC = 5 (1920x1080i @ 60Hz)

             Colorspace = YCbCr 4:4:4    PR = 0    Picture Aspect Ratio: 16:9

-Rx: 40:199 Configuring RX CSC:   YCbCr 444 --> YCbCr 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 40:203 Free-run CS is set to YUV

-VP: 40:207 Same AVI received. Input is YUV

-VP: 40:218 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 40:233 Same AVI received. Input is YUV

-VP: 40:244 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-Rx: 40:265 Channel Status: Not valid. N=6144

-Rx: 40:270 Received Audio Info Frame Packet:

             84 01 0a 01 00 00 00 00   00 00 00 00 00

-Rx: 40:501 Video is in Interlaced mode

-Rx: 40:501 Video timing measurements (pixels) :

             Filter 1 measurements (pixels) :

              Total Lines   = 563

              Active Lines  = 540

              Front Porch   = 2

              Sync Pulse    = 5

              Back Porch    = 15

             HS Total Lines   = 2200

             HS Active Lines  = 1920

             HS Front Porch   = 88

             HS Sync Pulse    = 44

             HS Back Porch    = 148

             VS Total Lines   = 562

             VS Active Lines  = 540

             VS Front Porch   = 2

             VS Sync Pulse    = 5

             VS Back Porch    = 15

             Horizontal Freq. = 33710 Hz

             Vertical Freq.   = 60 Hz

             Estimated Vic    = 5

-Rx: 40:501 Detected VIC = 5

APP: RX Video Stable = 1, data = 5

-VP: 40:526 Vsp App: HDMI Input video is detected

-VP: 40:526 Detected video:

             Vic   = 5

             Format= 1920x1080i60

             H-Pol = +ve

             V-Pol = +ve

             VfmPer= 0x45e6a9bd

-VP: 40:609 Starting bytes/pixel for Vsp1=4   Vsp2=4

-VP: 40:609 VSP1 Bandwidth = 0.00 GB/s

-VP: 40:609 VSP2 Bandwidth = 0.00 GB/s

-VP: 40:609 Comb Bandwidth = 0.00 GB/s

-VP: 40:609 Total Bandwidth (With OSD) = 0.88 GB/s

-VP: 40:612 OSD  pass-through -->TX1

            TX1 from OSD

-VP: 40:613 OSD  pass-through -->TX2

            TX2 from OSD

-VP: 40:614 OSD  pass-through -->Component

            Component from OSD

-VP: 40:619 OSD  pass-through -->CVBS

            CVBS & S-Video from OSD

-VP: 40:632 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 40:646 sending VS Infoframe without 4K or 3D info

-VP: 40:653 Sending VS Infoframe to TX1:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 40:663 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 40:674 sending VS Infoframe without 4K or 3D info

-VP: 40:683 Sending VS Infoframe to TX2:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 40:683 Vsp App: Input Video Frequency = 71MHz

APP: reset HDCP when HDMI video is stable

APP: Setting all ports HPD to HI.

-Rx: 40:893 Video is not locked, VIC is set to 0

APP: RX Video Stable = 0, data = 0

-VP: 40:893 Vsp App: HDMI Input video is detected

-VP: 40:894 Detected video:

             Vic   = 2

             Format= 720x480p60

             H-Pol = -ve

             V-Pol = -ve

             VfmPer= 0xc00d544b

-VP: 40:967 Starting bytes/pixel for Vsp1=4   Vsp2=4

-VP: 40:967 VSP1 Bandwidth = 0.00 GB/s

-VP: 40:967 VSP2 Bandwidth = 0.00 GB/s

-VP: 40:967 Comb Bandwidth = 0.00 GB/s

-VP: 40:967 Total Bandwidth (With OSD) = 0.88 GB/s

-VP: 40:969 OSD  pass-through -->TX1

            TX1 from OSD

-VP: 40:970 OSD  pass-through -->TX2

            TX2 from OSD

-VP: 40:971 OSD  pass-through -->Component

            Component from OSD

-VP: 40:975 OSD  pass-through -->CVBS

            CVBS & S-Video from OSD

-VP: 40:991 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 41:002 sending VS Infoframe without 4K or 3D info

-VP: 41:009 Sending VS Infoframe to TX1:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 41:020 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 41:031 sending VS Infoframe without 4K or 3D info

-VP: 41:038 Sending VS Infoframe to TX2:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 41:038 Vsp App: Input Video Frequency = 27MHz

-Rx: 41:116 @@@@ RX Mute State changed to 2

-Rx: 41:124 ----------> Int: Port A TMDS=0   1

-Rx: 41:125 ----------> Int: Intern Mute=1

-Rx: 41:126 ----------> Int: Port A PLL=0   1

-Rx: 41:131 ----------> Int: AIF-

-Rx: 41:133 ----------> Int: AVI-

-Rx: 41:138 ----------> Int: DE REGEN=0

-Rx: 41:140 ----------> Int: V Lock=0

-Rx: 41:144 ----------> Int: STDI Valid=0

-Rx: 41:147 ----------> Int: Aud N Change

-Rx: 41:161 TMDS Clock NOT detected on selected port (A)

APP: Freerun is ON. VIC is 2

-Rx: 41:169 @@@@ RX entering free-run

-Rx: 41:171 @@@@ RX started delay to unmute

-Rx: 41:181 Free-run CS is set to YUV

APP: Sending free-run AVI with Vic=2, CS=YUV

-VP: 41:185 Input AVI is YUV. No CSC.

-VP: 41:196 Sending AVI to TX1:

            82 02 0d 10 98 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-VP: 41:226 Same AVI received. Input is YUV

-VP: 41:234 Sending AVI to TX2:

            82 02 0d 10 98 00 02 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=4x3  Vic=2 (720x480p @ 60Hz)

-Rx: 41:262 Selected Port is (Gear): A

-Rx: 41:262 Video PLL LCK change on Port (Gear): A

-Rx: 41:262 Video PLL Not Locked Port A

-Rx: 41:262 Internal Mute On

-Rx: 41:263 @@@@ RX Mute State changed to 0

-Rx: 41:271 @@@@ RX unmute delay expired

-Rx: 41:288 Channel Status: Not valid. N=0

-Rx: 43:082 ----------> Int: Port A TMDS=1   1

-Rx: 43:082 ----------> Int: Port A PLL=1   1

-Rx: 43:083 ----------> Int: AV mute=0

-Rx: 43:084 ----------> Int: DE REGEN=1

-Rx: 43:089 ----------> Int: AVI+

-Rx: 43:094 ----------> Int: AIF+

-Rx: 43:095 ----------> Int: HDMI=1

-Rx: 43:105 TMDS Clock detected on selected port (A)

-Rx: 43:121 @@@@ RX Mute State changed to 2

-Rx: 43:128 @@@@ RX exiting free-run

-Rx: 43:129 Free-run CS is set to YUV

APP: Freerun is OFF

-Rx: 43:132 Selected Port is (Gear): A

-Rx: 43:132 Video PLL LCK change on Port (Gear): A

-Rx: 43:132 Video PLL Locked Port A

-Rx: 43:230 *******Default Eq Settings

-Rx: 43:233 Source signal changed to HDMI

APP: SOURCE is HDMI

-Rx: 43:233 AV Mute Off

-Rx: 43:233 Received AVI Info Frame (RAW) Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

-Rx: 43:234 Received AVI Info Frame Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

             VIC = 5 (1920x1080i @ 60Hz)

             Colorspace = YCbCr 4:4:4    PR = 0    Picture Aspect Ratio: 16:9

-Rx: 43:239 Configuring RX CSC:   YCbCr 444 --> YCbCr 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 43:242 Free-run CS is set to YUV

-VP: 43:248 Input AVI is YUV. No CSC.

-VP: 43:258 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 43:275 Same AVI received. Input is YUV

-VP: 43:287 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-Rx: 43:307 Channel Status: Not valid. N=0

-Rx: 43:316 Received Audio Info Frame Packet:

             84 01 0a 01 00 00 00 00   00 00 00 00 00

-Rx: 43:415 ----------> Int: Intern Mute=0

-Rx: 43:417 ----------> Int: V Lock=1

-Rx: 43:422 ----------> Int: AVI+

-Rx: 43:428 ----------> Int: AIF+

-Rx: 43:439 ----------> Int: Aud N Change

-Rx: 43:440 ----------> Int: FIFO_NEARUFLO=1

-Rx: 43:446 ----------> Int: STDI Valid=1

-Rx: 43:447 @@@@ RX started delay to unmute

-Rx: 43:503 Internal Mute Off

-Rx: 43:503 Received AVI Info Frame (RAW) Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

-Rx: 43:504 Received AVI Info Frame Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

             VIC = 5 (1920x1080i @ 60Hz)

             Colorspace = YCbCr 4:4:4    PR = 0    Picture Aspect Ratio: 16:9

-Rx: 43:508 Configuring RX CSC:   YCbCr 444 --> YCbCr 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 43:513 Free-run CS is set to YUV

-VP: 43:519 Same AVI received. Input is YUV

-VP: 43:528 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 43:544 Same AVI received. Input is YUV

-VP: 43:554 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-Rx: 43:569 @@@@ RX Mute State changed to 0

-Rx: 43:575 ----------> Int: AIF-

-Rx: 43:579 ----------> Int: AVI-

-Rx: 43:586 @@@@ RX unmute delay expired

-Rx: 43:601 Channel Status: Not valid. N=6144

-Rx: 43:607 Received Audio Info Frame Packet:

             84 01 0a 01 00 00 00 00   00 00 00 00 00

-Rx: 43:636 Channel Status: Not valid. N=6144

-Rx: 43:714 ----------> Int: AVI+

-Rx: 43:722 ----------> Int: AIF+

-Rx: 43:741 Received AVI Info Frame (RAW) Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

-Rx: 43:742 Received AVI Info Frame Packet:

             82 02 0d 40 a8 00 05 00   00 00 00 00 00 00 00 00

             VIC = 5 (1920x1080i @ 60Hz)

             Colorspace = YCbCr 4:4:4    PR = 0    Picture Aspect Ratio: 16:9

-Rx: 43:748 Configuring RX CSC:   YCbCr 444 --> YCbCr 444

             (RGB Range=Default)  (YCC Range=Limited)

-Rx: 43:752 Free-run CS is set to YUV

-VP: 43:756 Same AVI received. Input is YUV

-VP: 43:765 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 43:782 Same AVI received. Input is YUV

-VP: 43:793 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-Rx: 43:815 Channel Status: Not valid. N=6144

-Rx: 43:820 Received Audio Info Frame Packet:

             84 01 0a 01 00 00 00 00   00 00 00 00 00

-Rx: 43:875 Video is in Interlaced mode

-Rx: 43:875 Video timing measurements (pixels) :

             Filter 1 measurements (pixels) :

              Total Lines   = 563

              Active Lines  = 540

              Front Porch   = 2

              Sync Pulse    = 5

              Back Porch    = 15

             HS Total Lines   = 2200

             HS Active Lines  = 1920

             HS Front Porch   = 88

             HS Sync Pulse    = 44

             HS Back Porch    = 148

             VS Total Lines   = 562

             VS Active Lines  = 540

             VS Front Porch   = 2

             VS Sync Pulse    = 5

             VS Back Porch    = 15

             Horizontal Freq. = 33710 Hz

             Vertical Freq.   = 60 Hz

             Estimated Vic    = 5

-Rx: 43:875 Detected VIC = 5

APP: RX Video Stable = 1, data = 5

-VP: 43:898 Vsp App: HDMI Input video is detected

-VP: 43:899 Detected video:

             Vic   = 5

             Format= 1920x1080i60

             H-Pol = +ve

             V-Pol = +ve

             VfmPer= 0x45e6a9bd

-VP: 43:976 Starting bytes/pixel for Vsp1=4   Vsp2=4

-VP: 43:976 VSP1 Bandwidth = 0.00 GB/s

-VP: 43:976 VSP2 Bandwidth = 0.00 GB/s

-VP: 43:976 Comb Bandwidth = 0.00 GB/s

-VP: 43:976 Total Bandwidth (With OSD) = 0.88 GB/s

-VP: 43:979 OSD  pass-through -->TX1

            TX1 from OSD

-VP: 43:980 OSD  pass-through -->TX2

            TX2 from OSD

-VP: 43:981 OSD  pass-through -->Component

            Component from OSD

-VP: 43:985 OSD  pass-through -->CVBS

            CVBS & S-Video from OSD

-VP: 43:997 Sending AVI to TX1:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 44:009 sending VS Infoframe without 4K or 3D info

-VP: 44:016 Sending VS Infoframe to TX1:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 44:026 Sending AVI to TX2:

            82 02 0d 00 a8 00 05 00   00 00 00 00 00 00 00 00

            Color=RGB   Encoding=601, Limited range

            PixelRep=0  Aspect=16x9  Vic=5 (1920x1080i @ 60Hz)

-VP: 44:038 sending VS Infoframe without 4K or 3D info

-VP: 44:047 Sending VS Infoframe to TX2:

            81 01 04 6b 03 0c 00 00   00 00 00 00 00 00 00 00

            00 00 00 00 00 00 00 00   00 00 00 00 00 00 00

-VP: 44:047 Vsp App: Input Video Frequency = 71MHz

APP: reset HDCP when HDMI video is stable

 

Receiver>

 

Stat command shows everything looks OK

 

Receiver> stat

 

HDMI RX Status:

Port     = A

TMDS CLK = ON

Video PLL= LOCKED

Vid Det. = YES

Input    = HDMI

AV Mute  = OFF

Muted    = NO

Encryptn = OFF

Col Depth= 24 Bits

Output CS= YUV

Aud type = ASP

Freerun  = NO

3D Video = NO

VIC      = YES (5)

Input Timing  = 1920x1080i60

 

HDMI TX1 Status:

Chip PD  = NO

TMDS     = **** OFF ****

HPD      = **** NO ****

Mon sense= YES

PLL lock = **** NO  ****

Out mode = DVI

Vid mute = NO

Clear AVM= YES

Set AVM  = NO

Aud Rept = **** DIS  ****

SPDIF En = **** NO  ****

I2S En   = **** NO  **** (0x0)

Det.InVIC= YES (5)

Encryptn = OFF

 

HDMI TX2 Status:

Chip PD  = **** YES ****

TMDS     = **** OFF ****

HPD      = **** NO ****

Mon sense= **** NO ****

PLL lock = **** NO  ****

Out mode = DVI

Vid mute = NO

Clear AVM= **** NO  ****

Set AVM  = NO

Aud Rept = YES

SPDIF En = **** NO  ****

I2S En   = YES (0xf)

Det.InVIC= YES (5)

Encryptn = OFF

 

Curr Mode = Repeater

Det. Mode = Receiver

 

Receiver>

 

Apply +5V

-T1: 03:404 HPD changed to HI

HAL_EnableTxHPD: Not implemented

                                -T1: 03:564 #### Muted using: TMDS AVMUTE BLKOUT ASP (TX PLL not locked)

HAL_PlatformTXInit: Not implemented

 

Stat command shows we see something on the Tx side.

 

Repeater> stat

 

HDMI RX Status:

Port     = A

TMDS CLK = ON

Video PLL= LOCKED

Vid Det. = YES

Input    = HDMI

AV Mute  = OFF

Muted    = NO

Encryptn = OFF

Col Depth= 24 Bits

Output CS= YUV

Aud type = ASP

Freerun  = NO

3D Video = NO

VIC      = YES (5)

Input Timing  = 1920x1080i60

 

HDMI TX1 Status:

Chip PD  = NO

TMDS     = **** OFF ****

HPD      = YES

Mon sense= YES

PLL lock = **** NO  ****

Out mode = DVI

Vid mute = **** YES ****

Clear AVM= **** NO  ****

Set AVM  = **** YES ****

Aud Rept = **** DIS  ****

SPDIF En = **** NO  ****

I2S En   = **** NO  **** (0x0)

Det.InVIC= YES (5)

Encryptn = OFF

 

HDMI TX2 Status:

Chip PD  = **** YES ****

TMDS     = **** OFF ****

HPD      = **** NO ****

Mon sense= **** NO ****

PLL lock = **** NO  ****

Out mode = DVI

Vid mute = NO

Clear AVM= **** NO  ****

Set AVM  = NO

Aud Rept = YES

SPDIF En = **** NO  ****

I2S En   = YES (0xf)

Det.InVIC= YES (5)

Encryptn = OFF

 

Curr Mode = Repeater

Det. Mode = Repeater

 

Repeater>

 

But still nothing on the TMDS .

 

Any suggestions? I have all the commands from rep_console.c available to me. I've already tried insel/src/out, even pout commands and nothing seems to happen.

Outcomes