AnsweredAssumed Answered

ADIS16488A SPI Communication Troubles

Question asked by Gwango on Feb 26, 2015
Latest reply on Apr 25, 2015 by NevadaMark
Branched to a new discussion

Hey everybody, first post here, so let me know if I leave out some vital information.

 

I work in a lab at a school, and we have been trying to read data from our ADIS16488A IMU with a Beaglebone Black's SPI interface. I have studied the spec sheet of both to look for an obvious answer, and have also looked at this topic to see if the problem was similar. I was hopeful when I saw that a breadboard was used, as we do not have the budget for the evaluation board for this IMU. We have the breakout board, as well as a wire harness that was made in the lab to connect the ADIS to the Beaglebone via a breadboard, but I don't have the same crosstalk problem as in the other topic. I have checked continuity across all of the connections and everything seems to be in order; here's my issue.

 

I am able to write data correctly to the ADIS; the clock and data seems to be in sync for the IMU to sample it correctly. However, when I attempt to access the product ID register (register 0x7E; shown below), I get a response of 0x00 as opposed to the expected 0x4068. After attempting to access other registers (gyro output registers), I still get a response of 0x00.

 

adis1.png

Attempting to read from 0x7E

adis2.png

Same waveform, zoomed in

 

 

When I figured the IMU was likely dead and that the Beaglebone was what was causing DOUT to go low, but I tried the same code with the ADIS detached and received 0xFF instead.

 

noadis2.png

 

Any ideas on what I might be missing out on? Any input would be appreciated, and please let me know if you need more information. Thanks!

 

Edit for more info: I am currently using python to code the Beaglebone and using the Adafruit_BBIO library for the SPI functions.

Outcomes