AnsweredAssumed Answered

AD7147 SPI problem

Question asked by iliar on Jan 19, 2015
Latest reply on Jul 24, 2015 by Kristof_Mulier

Hi. I'm having some issues with AD7147 SPI communication.

 

I tried reading a register from it but the SDO remains high always. it ripples a little when I write the command word but it doesn't ever change to low.

 

I configured the AD7147 registers exactly as it says in the Power-Up sequence of the datasheet, I wrote the registers, then tried to read them and it remains high.

I tried it on another AD7147 I own with the same results. AD7147 PACPZ - 500 and AD7147 ACPZ -500

 

I'm using a NUC123 microcontroller, I use its 3.3V supply for the AD7147, I connect it both to the V-Drive and the Vcc pin.

 

In order to easily capture the communication on an oscilloscope I lowered the SPI speed to 10kHz. (the problem existed for higher speeds of 1MHztoo).

 

My circuit is exactly the same as in the datasheet page 42 (Typical application circuits) only without any buttons/sliders attached (CIN are all floating).

 

I've seen a similar post: https://ez.analog.com/message/170381#170381 but I don't use voltage higher than 3.6 so it's not the same case.

 

I attach to this question plots from the oscilloscope.

 

Thank you very much.

Outcomes