AnsweredAssumed Answered

Build of 2014_R2 HDL not working

Question asked by apillai2011@gmail.com on Jan 15, 2015
Latest reply on Jan 21, 2015 by CsomI

Hello,

 

This is a continuation of mails from this thread: https://ez.analog.com/message/160884#160884 since new mails in that thread seem to getting moderated for some reason (maybe the thread is getting too long?)

 

I am mailing because the BOOT.BIN I built using the instructions provided for 2014_R2 (with Vivado 2014.2 and Xilinx SDK for 2014.2) is not working.

 

I am describing the procedure I followed below:

 

1. I checked out the hdl_2014_r2 branch from analogdevicesinc/hdl · GitHub I built it using vivado 2014.2 using the instructions here: ADI Reference Designs HDL User Guide [Analog Devices Wiki] . Specifically:

(a) I went to each directory in hdl/library and executed:

$ vivado -mode batch -source <dirname>_ip.tcl

(b) After this I went to fmcomms2/zed/ and executed:
$vivado -mode batch -source system_project.tcl

 

2. I checked out u-boot as per instructions here: Latest u-boot version for ZYNQ+AD9361 using Xilinx/u-boot-xlnx · GitHub xilinx-v2014.3 branch. I built mkimage using Vivado 2014.4 SDK. I also built u-boot.elf here, but the built u-boot.elf did not work when I tried to create the BOOT.BIN with xsdk, so I used the u-boot.elf attached in the thread https://ez.analog.com/message/160884#160884 by Dragos.

 

3. I built a BOOT.BIN using the SDK project generated by (1), and the u-boot.elf attached in the other thread.

 

4. I checked out the 2014_R2 branch from analogdevicesinc/linux · GitHub I set the ARCH and CROSS_COMPILE appropriately to use Vivado 2014.2 for ARM and built this Linux. As mentioned in (2), I am using the mkimage built in the downloaded u-boot-xlnx to create the uImage.

 

5. I also built the devicetree.dtb for "zynq-zed-adv7511-ad9361-fmcomms2-3".

 

6. I then copied the BOOT.BIN, uImage and devicetree.dtb that I built using Vivado 2014.2 compiler binaries to the BOOT/ partition as per instructions here: Building the 2014_R2 release Linux kernel and devicetrees from source [Analog Devices Wiki]

 

7. I also copied the Linaro file system to the rootfs/ partittion from the SD card binary image here:https://ez.analog.com/message/167891?et=watches.email.thread#167891

 

I connected a USB cable to the UART and tried to connect to the board via minicom/screen, but I do not get any prompt even though the blue light glows on the board when I boot.

 

I then replaced the BOOT.BIN that I built with the BOOT.BIN in the SD card binary image in the 2014_R2 release above (while still keeping the uImage and the devicetree.dtb that I built) and everything works - I am able to connect via minicom and get to a root login prompt.

 

So, there is some problem with the BOOT.BIN even though I followed the full instructions to build using Vivado 2014.2 and SDK. I am not sure where the problem is - whether it is in the Vivado stage or the SDK stage etc. Could you please suggest some way to debug/figure this out? I can attach logs from the HDL compilation or SDK if you believe they might be useful.

 

Thanks in advance for any help you can provide!

Arun

Outcomes