AnsweredAssumed Answered

ADV7181D YPrPb input support ?

Question asked by zbunix on Jan 6, 2015
Latest reply on Jan 9, 2015 by mattp

Our use case is as follows:

Input:

    525p/60Hz YPrPb

  

Output:

  YCbCr  8Bit 422 HS/VS

  VS pin and DE pin are used. (SAV/EAV is not used.)

 

script configure:

##CP 525p/625p##

:525p/60Hz YPrPb In 8Bit 422 HS/VS Encoder:

42 05 01 ; PRIM_MODE = 001b COMP

42 06 06 ; VID_STD for 525P 2x1

42 C3 56 ; ADC1 to Ain8, ADC0 to Ain10,

42 C4 B4 ; Enables manual override of mux & ADC2 to Ain6.

42 1D 47 ; Enable 28.63636MHz crystal

42 3A 11 ; Set Latch Clock 01b. Power down ADC3.

42 3B 81 ; Enable Internal Bias

42 3C 3B ; PLL QPUMP to 011b

42 6B 83 ; 422 8bit out

42 C9 00 ; SDR mode

42 73 CF ; Enable Manual Gain and set CH_A gain

42 74 A3 ; Set CH_A and CH_B Gain - 0FAh

42 75 E8 ; Set CH_B and CH_C Gain

42 76 FA ; Set CH_C Gain

42 7B 1C ; Turn off EAV and SAV Codes. Set BLANK_RGB_SEL.

42 85 19 ; Turn off SSPD and force SOY

42 86 0B ; Enable STDI Line Count Mode

42 BF 06 ; Blue Screen Free Run Colour

42 C0 40 ; default color

42 C1 F0 ; default color

42 C2 80 ; Default color

42 C5 01 ;

42 C9 08 ; Enable 8-bit mode using psuedo DDR

42 0E 80 ; ADI recommended sequence

42 52 46 ; ADI recommended sequence

42 54 80 ; ADI Recommended Setting

42 57 01 ; ADI recommended sequence

42 F6 3B ; ADI Recommended Setting

42 0E 00 ; ADI recommended sequence

42 67 2F ; DPP Filters

End

 

our sch file

YPbPr_sch.png

 

Question 1

520P YPbPr input no work OK( no video image disaplay) blue screen bug, help us check?

 

Question 2

Y ---- ADC0   Pb --- ADC1  Pr --- ADC2  right? configure other (e.g. Y--ADC3 Pb--ADC2) ?


Question 3

1) remove horizontal blank, only have active data(720x2=1440), similar CMOS sensor output(HREF pin) timing ?  from  pin  DE mode

2) remove vertical blank line, only have active line (480 line), similar CMOS sensor output(VSYNC pin) timing ?     from pin VS

our post need timing :

post_timing_diagram.png



Regards,

Outcomes