AnsweredAssumed Answered

no video output from ADV7513

Question asked by yimiqiba on Dec 16, 2014
Latest reply on Dec 18, 2014 by GuenterL

hi,adi,

   I met some problems about ADV7513 in my design.No video output from ADV7513.

  

   ADV7513 INPUT:

                     video:  YCbCr,4:2:2,10bit color depth,embedded Sync,

                     audio:  48k,i2s

   Data pin connection:

                                        Y[9:0]-->D[13:4],

                                        CbCr[9:0]-->D[23:14]

 

   Registers map:

Main map

0x01

0x00

Set N Value(6144)

0x02

0x18

Set N Value(6144)

0x03

0x00

Set N Value(6144)

0x15

0x22

Input 422 YCrCb with embedded Syncs, 48kHz fs

0x16

0x95

Output format 422, 10-bit input

0x18

0x46

CSC disabled

0x40

0x80

General Control packet enable

0x41

0x10

Power down control

0x48

0x08

Data right justified

0x49

0x00

No truncation

0x4C

0x00

10 bit Output

0x55

0x20

Set YCrCb 422 in AVinfo Frame

0x56

0x08

Set active format Aspect

0x96

0x20

HPD Interrupt clear

0x98

0x03

ADI Recommended Write

0x99

0x02

ADI Recommended Write

0x9C

0x30

PLL Filter R1 Value

0x9D

0x60

Set clock divide

0xA2

0xA4

ADI Recommended Write

0xA3

0xA4

ADI Recommended Write

0xA5

0x04

ADI Recommended Write

0xAB

0x40

ADI Recommended Write

0xAF

0x16

Set HDMI Mode

0xBA

0x60

No clock delay

0xD1

0xFF

ADI Recommended Write

0xDE

0xD8

ADI Recommended Write

0xE4

0x60

VCO_Swing_Reference_Voltage

0xFA

0x7D

Nbr of times to search for good phase

0x30

0x84

 

0x31

0x02

 

0x32

0xC0

 

0x33

0x08

 

0x34

0x05

 

0x35

0x2F

 

0x36

0xD4

 

0x37

0x0F

 

0x38

0x00

 

0x39

0x21

 

0x3A

0xC0

 

0xD7

0x84

 

0xD8

0x02

 

0xD9

0xC0

 

0xDA

0x08

 

0xDB

0x05

 

      Schematic:(R60 not place)

         SCH.bmp

Outcomes