AnsweredAssumed Answered

problem with FPGA board

Question asked by shide on Nov 29, 2014
Latest reply on Dec 4, 2014 by David.Buchanan

Good day! Our group works at the JINR (Joint Institute for Nuclear Research, Russia, Dubna) and we engage in automation and data processing in physical experiments. We bought an Analog Devices HSC-ADC-EVALC board last year. Our aim is to digitize signals and transfer them by USB to PC and then process them. We used an ADC AD9627 board and HSC-ADC-EVALC for it. We would like to use the Visual Analog software in Samples mode and using it to save counts in a file. But we had a problem. We were not able to synchronize a waveform record and input signal. We had an empty image all time (the pulses' frequencies are low and an emergence of a pulse is a random process).

 

We had set a task to write new firmwares for FPGA and Cypress controller (for slave fifo mode). The task was completed. We were successfully working with the board before a certain time. But we have had an another problem now. The board is unable to being detected after loading our new firmare to the Cypress controller. A PC just do not detect controller as an USB device (VID = 0x0000, PID = 0x0000). But sometimes a PC could detect the board. We tried to solve this problem. We tried to reflash the EEPROM of the USB controller. So a native firmware has been erased and replaced by our firmware. But we were not able to solve the problem.

 

We cannot explain the reason of this bug. May you give us a native (original) firmware of a controller (.hex or .iic file) ? We would like to test the controller with  native firmware and determine the reason of the problem. Thank you.

Outcomes