AnsweredAssumed Answered

SigmaStudio v3.2 and defected USBi interface

Question asked by ChUmI on Oct 19, 2010
Latest reply on Nov 9, 2010 by JeradL

For one of my customers I am developing currently a project - studio-grade near field active monitor, a kind of active loudspeaker. This product shall be introduced to the market in the middle of the 2011. Complete audio signal processing is done by ADAU1701 SigmaDSP (active crossover, tone/volume control, limiter, etc…). The first version of the hardware is already released and first samples should be produced soon. At the moment we develop SW for SigmaDSP. Yesterday I installed new version of SigmaStudio - v3.2 and unfortunately one problem has popped out. We develop the SigmaDSP SW using a standard ADAU1701 Mini Eval-Boards with the USBi interface. I do not know when exactly it happened, I worked already more than hour with it, but all at once I notice that I can not flash my eval-board with the USBi any more. I noticed also that SigmaStudio can not detect the USBi interface and on the USBi interface the yellow I2C LED is switched off. I would not think that the USBi interface could be electrically damaged because it was connected only to the original ADI eval-board and the board was supplied from the USBi interface – no external supply, no other external connections – aoutio out connected to headphones. I tried to disconnect and connect again the USBi board but it didn’t help. It looks the USBi interface somehow doesn’t work anymore.

 

I had in the office one more USBi interface. I connected it to the eval-board and flashed the board without any problem – it shows that the eval-board works OK. After flashing I tried to connect back the first USBi interface but it still didn't work Next I connected back the second (working) USBi interface and now the second USBi also doesn’t work! I have no clue what could happened??? Somehow the both USBi don't work and I can not develop my project anymore.

 

It looks like both USBi boards behave now similar – no USB communication / I2C LED off. I checked shortly voltages on the board and everything looks OK. I check also with the osciloscope the clock of the on-board microcontroller and it looks also OK – stable, nice 24MHz clock. For me it looks like the Cypress microcontroller lost his firmware in both cases – is it possible??? Everythink looks OK (electrically) but the Cypress doesn't work. There is also complettly nothing on the USB BUS after connecting (power-on) the USBi to USB.

 

I worked on the SW already for several days and I never had any problems with SigmaDSD<->USBi. I've been familiar with SigmaDSP and SigmaStudio for 2 years and I've also never seen a problem like that. The strange thing is, the second USBi was “defected” right after the first one and behaves now similarly. I know the USBi Firmware can be updated directly from SigmaStudio, therefore I suppose in this case, somehow by accident, SigmaStudio damaged the Cypress firmware trying flashing SigmaDSP eval-board.

 

Could someone from ADI support help me? Can I somehow reflash the USBi with the new firmware? Can I send my USBi somewhere to reflash it or can I get the boards replaced – the one I bought a week before, is practically brand new. Unfortunately I can not work on the project without the USBi interface.

 

Best Regards,

Tomasz

Outcomes