AnsweredAssumed Answered

ZedBoard & fmcomms2 : running iiostream example

Question asked by Seb@Airbus on Nov 19, 2014
Latest reply on Dec 10, 2015 by mn@ut

Hello,

I've bee trying to run the iiostream example from the iio library following the step described in

http://wiki.analog.com/resources/tools-software/linux-software/libiio

I successfully compiled the library and examples, then got the following error when running ad9361-iiostream :

Error -2 writting to channel "rf_port_select"

Looking at the source code, the error seems to be generated when calling

iio_channel_attr_write_raw in channel.c @ 226

cfg_ad9361_streaming_ch (RX) in ad9361-iiostream.c @ 202

 

I looked for a solution in the following thread AD9361+Zedboard and AD9361_iiostream example

but unlike this person, i do have /dev/iio\:device3 and /dev/iio\:device4

 

Here attached are the logs of ./examples/ad9361-iiostream and ./test/iio_info

 

If you have any idea what the problem is, help would be appreciated

 

Thanks in advance

Sébastien

 

PS : i tried on another SDCard with a save of the original data (marked as January 2014 on the SDCard), redownloaded and installed the libiio, and still got the same error. I then ran the ad_update_boot.sh script, and still the same error.

Attachments

Outcomes