AnsweredAssumed Answered

Problems with established project when upgrading from VDSP++5.0.0 to 5.1.1

Question asked by PAULWRIGHT on Nov 3, 2014
Latest reply on Nov 6, 2014 by PAULWRIGHT

Hello,

 

I have an established and reliable project that uses VDK and LWIP.  It takes data from several ADCs using PPI/DMA, parcels it up and sends to a PC using TCPIP sockets.  All works well.

 

I have just upgraded from my ancient VDSP++ V5.0.0  to the latest V5.1.2.  My project builds OK and runs but it performance is no longer reliable.  After some tens of seconds some of the data gets lost. Even more strange I sometimes get an exception:

KThreadError --> kInvalidTargetDSP

 

Has anybody else experienced similar issues when updating VDSP++?

 

My thanks in anticipation.

 

Cheers

 

Paul

Outcomes